Librespot is not identifiying correctly using hutspot, but it's working with cli?


I don’t know if this is normal or not, But when I try to run hutspot and register my credentials for librespot I’ve got this Error/stacktrace in terminal:

[D] :345 - callback error: null, exitCode: 101, data: INFO:librespot: librespot UNKNOWN (UNKNOWN). Built on 2019-02-22. Build ID: leZr8GGQ
INFO:librespot_core::session: Connecting to AP “
thread ‘main’ panicked at ‘Authentication failed with reason: BadCredentials’, core/src/connection/
stack backtrace:
0: 0xbc0a0af - std::sys::imp::backtrace::tracing::imp::unwind_backtrace::hc84c7750073bd460
1: 0xbc05bf7 - std::sys_common::backtrace::_print::ha0d301943d8aa984
2: 0xbc0ed2b - std::panicking::default_hook::{{closure}}::h3ba1f9aa602f147d
3: 0xbc0ea3b - std::panicking::default_hook::h99a47e6dd7455d43
4: 0xbc0f29b - std::panicking::rust_panic_with_hook::h56366b27cd53256d
5: 0xbc0f0eb - std::panicking::begin_panic::hc452e5a463a77b1b
6: 0xbc0f06b - std::panicking::begin_panic_fmt::h1d7fc6d4081886d5
7: 0xb932d6f - <futures::future::and_then::AndThen<A, B, F> as futures::future::Future>::poll::h1bccaa2de9cad160
8: 0xb97ea6f - <futures::future::map::Map<A, F> as futures::future::Future>::poll::h0ded3ad25caea9c9
9: 0xb80d663 - <futures::task_impl::Spawn>::enter::{{closure}}::h84ade8ffea6670fd
10: 0xb80d127 - <futures::task_impl::Spawn>::enter::{{closure}}::h02bb2a1d31967f9c
11: 0xb829f73 - librespot::main::hf6e6c045ca8eb366
12: 0xbc14693 - __rust_maybe_catch_panic
13: 0xbc0fabb - std::rt::lang_start::ha6336c7a6712f940
14: 0xe8c78aef - __libc_start_main

But If I run librespot using the terminal, I’ve got everything working.


are you sure the credentials used are good?
The above message seems to indicate the contrary.

Also, are you using a Spotify Premium account? This is required for hutspot/librespot to work

I tried to type the passsword several times, and this is why I commented that using the bash, it worked fine.

Also, I tried changing my password.