Library for the clients "sailfisheas-contacts"/"sailfisheas-calendars" do not exist using Microsoft Exchange

Ahoy sailors!

I broke my Xperia X a few month ago and bought a second hand Xperia 10 II. I flashed it this friday with Kvarken 4.1.0. It’s so good to get back to Sailfish OS!

I struggle to synchronize my contacts and calendar using Microsoft Exchange.

 

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.1.0.24
HARDWARE (XA2, Xperia 10…): Xperia 10 II
UI LANGUAGE: French
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

Data won’t synchronize from a Microsoft Exchange account.

PRECONDITIONS:

Install the Microsoft Exchange app and set-up an account. The account creation is working, so I guess my credentials and settings are correct, plus I did that on my Jolla Phone, Jolla Tablet and Xperia X before.

STEPS TO REPRODUCE:

  1. Go to Settings / Accounts / Microsoft Exchange
  2. From the pulley menu select Synchronize

EXPECTED RESULT:

Contacts and Calendar should be synchronized.

ACTUAL RESULT:

It’s not…

ADDITIONAL INFORMATION:

I tried to remove the Microsoft Exchange app, the account then starting over with the same result. After activating the developper mode, I checked journalctl while launching a new synchronization and got these warnings:

[C] unknown:0 - Library for the client "sailfisheas-contacts" does not exist
[W] unknown:0 - Failed to create client plug-in: "sailfisheas-contacts"
[W] unknown:0 - Failed to initialize client plug-in runner
[W] unknown:0 - Internal error, unable to start sync session for profile: "sailfisheas.Contacts-8"
[C] unknown:0 - Library for the client "sailfisheas-calendars" does not exist
[W] unknown:0 - Failed to create client plug-in: "sailfisheas-calendars"
[W] unknown:0 - Failed to initialize client plug-in runner
[W] unknown:0 - Internal error, unable to start sync session for profile: "sailfisheas.Calendars-8"

I tried to remove then reinstall the calendar app to no end. I don’t know of any way to reinstall the contact app.

I checked the release notes’ known issues and the forum but found nothing related to this problem.

Does anyone encountered that and/or know how to solve it?

Regards.
A.