Keyboard stuck in numeric mode

I have seen this a couple of times, but never was that app involved. I don’t think it has to do with anything crashing either .

1 Like

After never having this bug (on any release, including 4.3) I now have it regularly since yesterday. Yesterday I installed and used the Value Logger app by @slava to track our local Covid data. It s brilliant and very useful app, but as soon as you use it to enter numeric data then they keyboard gets stuck as a numeric keyboard and this is displayed thereafter for any app when you click on any input field. I can get my text keyboard back by restarting the home screen in Sailfish utilities, but it is very frustrating.

If you have Jolla’s Utilities installed, there is an option to restart Home screen. That has helped me with this issue.

1 Like

This happened sometimes on my two Xperia 10’s running SFOS 4.3.0.12 . No idea from what it depends. I could always solve it by restarting the screen with ‘Hilfsprogramme’.

Funny, as it happens I observed this behavior for a while now, too (Xperia X with 4.2.0.21)
But I was able to attribute it to a single app: It’s ‘Olive goes shopping’ by @pawel.spoon. hadn’t had the time to report it yet.

The app uses both alphanumeric and numeric keyboard modes on one page (used to add articles to the shopping list). when exiting that very page after entering a number value with the numkeyboard active, that mode remains.
If I focus back on an input field for strings (alphanumeric) and close the app after, everything is fine.

So I suspect that there might be some QML property or other mechanism missing that resets the keyboard mode to alphanumeric since e.g. the Sailfish Calculator doesn’t even have any text input but still it does not cause the numkeyboard to stick scratch that. Calculator does not even use any keyboard, just buttons. Sailfish People (obviously) has number only input fields.

interesting and good for reproduction.
however, all i do.is to set a property of an input field to numeric …
so do not see a fault on my side

and i cant reproduce it.
select modify from pull menu, go and set focus of amount field, close app
go here and click on reply, all fine.

2nd try with notes is also working

please share a step by step repro.
i am on 4.3 on gs290, using latest olive-goes-shopping 4.1 version / 64bit

Indeed. I cannot reproduce it myself. Odd
Everytime the num keyboard got stuck in the past, it was after using Olive Goes Shopping. Opening it again and focusing a text entry fixed it.
But I haven’t made these observations systematic.Sorry

Will keep an eye on it if I can find a way to reproduce

I can reproduce this reliably every time on an XA2 4.3 by using Slava’s value logger app. This gives you a numeric keyboard to enter data values. Once you have done this you’re stuck with the numeric keyboard only in any following app usage - email, browser, messages, whatever. There’s no way to get the normal keyboard back again. The way I ‘fix’ the problem is to use Sailfish utilities to testart the home screen and all running apps.

For me it happens now only in landscape mode (in 4.2 it also happened in portrait mode). I tried with value logger app and BeamCalc (previously also Estonian mobile-ID). If I opened after that Skype in portrait, it (and keyboard) worked fine. If I opened Skype in landscape, the keyboard was stuck in numeric mode. Looks like it’s 100% reproducible for me.