Keyboard stopped working on android apps

Using Sailfish on an Xperia XA2 upgraded the other day to newest sailfish without problems. Have not done anything on the phone but today from like noon onwards, the keyboard refuses to work on Android apps.

I can select the input fields and the keyboard appears, but everything I write does not show in the field. Also, the keyboard now covers the input field where before the screen would jump so the field would stay visible.

Have already tried unistalling and reinstalling alien-dalvik but problem persists. Anybody any suggestions?

1 Like

Just got this same problem. What I did was I restored my original /opt/alien/system.img as I was using “MindTheGapps” version which apparently seemed to cause issues after the 3.4.0.24 update like, e.g., apps starting in black screen and no more notifications from Teams or Snapchat. I removed all the google stuff and installed MicroG stuff in place. Early on I noticed the same problem described above. I haven’t tried alien-dalvik reinstallation though.

I have the same problem. Version 3.3.0.16 worked. After update to 3.4.0.24 my Jolla is not usable anymore.

Can confirm that solution mentioned by _at33sa works (sorry for late reply, thanks for solution). But am sad to say that after having come back to Sailfish last year and using my XA2 as a daily driver (after having used a Jolla 1 for 4 years), I am now a bit fed up with the constant breaking of the phone, even at times when nothing has changed. I love Linux and have bought a Nexus 5x cheap online to play around with Plasma Mobile only to be told that my phone is not a Nexus 5x by the install script (which it is)… So I concluded that Linux on mobile still has a long way to go and therefore have installed a ROM without google on the old Nexus 5x for now. Will be keeping an eye on sailfish though with the XA2.

1 Like

You actually got the keyboard working again?? I did reinstall alien-dalvik and then installed Play Store again using the “MindTheGapps” system.img. I ofc removed all the MicroG stuff before that. Keyboard remains broken on the Android side and can’t login back to Snapchat anymore. (Detects phone’s rooted) Also can’t login to Tinder either, because it cannot get a location. I wish I could mock it somehow like in 4.4. Nothing of value has been lost though. The few people there will eventually realise they no longer can’t reach me, but whatcha gonna do. :tipping_hand_man: