[JP1] Device lock code seems corrupted

I messed up my Jolla 1 and had to reset it to factory, which I did.
Now, after performing all the updates until 3.4.0, I want to restore some data from the recovery mode (not while the phone is running).

My problem is that no matter what I do, I can’t get the shell in recovery mode as it’s always telling me that I have the Wrong code, try again although I know that I have the right one since it passes when I start normally.

I tried to reset it a few times and even went through Can't set new lock code - #13 by Sthocs to set back the original code I want to keep using but none worked in recovery.

I can unlock my phone just fine and I do have root access from FingerTerm with devel-su but I can’t access the shell from recovery mode.

Any idea on what I can do?

Note: I don’t know if it’s important but there is no SIM card in the phone since the reset.

I had the same problem. You have to remove your lock code.

Thanks, it worked but there is still an issue: if I set a security code again, I loose access to the recovery so I must keep my device unprotected to ensure I will remain able to recover from any mess I do.

Isn’t there any way to reset it somehow so that it works again?