Jolla tablet issue

Hello, bumped into the classic update issue. Could not believe the update to the latest Pallas-Yllästunturi was still going on and shut down the tablet. Did not remember to check backround lighting. Now the tablet does start anymore. Can someone point me to existing instructions how to overcome this issue? I wish Jolla implemented some sort of hourglass feature to work around this issue in the future, if it is not too late.

This may help you;

1 Like

Thanks a lot for this link @Edz!

Hi, unfortunately Recovery Mode does not open. Telnet cannot connect. The tablet shows “RECOVERY: Connect…” , though. I am using EndeavourOS Linux. What else can I do?

You need to activate the virtual ethernet interface on your linuy machine and afterwards you can connect via telnet. try to ping
the tablet should answer you

1 Like

How to do the first, virtual ethernet?

When you connect your tablet in recovery mode, your Linux notebook get automatically new ethernet device. You need to choose this device in connection manager. Thats all. So like you youse your WLAN or other network interaces…

1 Like

I don’t think I have any connection manager. Probably I need to do it manually, but I have no idea how the needed devices are called and where they reside in this Linux.

I gave ifcfg command on enp5s0 interface and suddenly ping started working unless it is a looped interface. Anyway, telnet is rejected.

1 Like

My tablet choked on the 4.0 update and now I’m encountering the same problem as @vpp. responds to ping, but


simply replies

telnet: telnet: bad port

What’s going on here and how can I/we solve it?

Edit: alright, I fixed the telnet problem by simply adding ’ 23’ without the quotes to the end of the telnet command. Now I have another question: can I somehow retrieve the data that’s in the home directory before I perform a factory reset?

mount /dev/sailfish/home to some location and copy to your sdcard or so

1 Like

Thanks, that worked perfectly. After the reset I was able to update to 4.0 with no problems, and copying the files from the SD card back to the tablet was also easy to do.

However, today my tablet apparently crashed, because it was off when I came home, so I tried turning it on again, and now it’s back to being stuck on the bootsplash. Any idea what could be wrong? Do I have to reset it again?

Edit: after endless tries holding the power button, tapping it, holding the volume buttons, tapping the power button whilst holding the volume buttons, etc, I suddenly managed to make it boot again.