Jolla Store Android apps install errors. Second issue: Apk browser downloads uninstallable

New phone - Sony Xperia ii, new system - SFOS Jolla Store Android apps:
Impossible to install due to repeated Jolla Store download errors.

I also tried downloading the F-Droid apk, but there is no longer an option to install files in File Browser @ichthyosaurus in the newest system version. Untrusted software is activated, but hasn’t helped.

Sailfish apps install fine, jist not Android? If so, mayne try signing out of Jolla account and sign back in, see if any change…

Installing .apk files from file browser via tapping the icon or app name (right white dot) doesn’t work, but installing via pull down menu + “open” works fine.

Did it this way with .apk’s downloaded from apkpure.

Possibly server issue on Jolla side?
Youbdo have Android Support installed?
You are able to download native apps?
sign out of jolla account, reboot, sign in, assure Android runtime is installed, reboot, try again

This then seems to be a second issue and should be separated. Maybe as bug report even?
But I do not get it. Which file browser? The one from system settings (jolla internal)? You just need to tap on it.
@Seven.of.nine the internal does not have a right white dot and no pulley menu, just tapping on it…???

No way to sign out of the Jolla account and sign back in on SFOS that I can find. only option is to delete account.

No way to sign out of the Jolla account and sign back in on SFOS that I can find. only option is to delete account. How do I check to make sure that the Android runtime is installed?

In SFOS, if I open “File Browser” by icthyosaurus that I downloaded from the Jolla Store, I navigate to my downloads folder and select the .apk (from the F-Droid website), use the “open” option in the pulley menu, it opens the Jolla web browser and starts to download the file again. only other options in pulley menu are to view raw content or change permissions. If I tap on the file icon, a new panel opens with the following:
** command “unzip” not found
If I tap on the icon for the file in the web browser “transfers” panel, I get the following:
File type ‘application/’ is not supported

That seems to suggest that the Android runtime did not get installed, despite my having purchased a Sailfish X license and only using SFOS on one phone…

I just tried deleting my Jolla account and recreating, plus a reboot, but nothing changed. Still have exactly the same messages.

Erm, the Android Runtime does not get installed automagically.
You need to select it from offered apps from Jolla Store (Jolla section) .
You need (of course) use same account on phone with which you bought the license.
If it is not available to you then you need to contact Jolla care


And regarding the file browser:
please also edit your first post to make it clear that you meant @ichthyosaurus file browser (a very good choice! :)) and not the Jolla internal one from system.settings.

What makes me wonder is the error message ‘unzip not found’ because I just installed it from Jolla store on a fresh updated test device and it works.
How did you update/flash your system?

And if seven.of.nine also meant ichthyosaurus browser then this is niormal behaviour she described.

Done. I wasn’t even aware of the Jolla internal file browser as it is so well hidden in the storage area. Elegant, but not very easy to discover…

I flashed the system as per the instructions for the Sony Xperia 10 ii, but suspect that the error has something to do with my lack of Android runtime.

Just now new flashed my Xperia 10 single SIM with the System and checked the behavior on installing .apk’s by file browser:

  1. went to the .apk using file browser - on the SD-card in my case
  2. Tap on .apk file → a page opens with icon, name, cut, copy, options, trash, rename, and some properties. right is the app name. tapping on icon or name both leads to an error msg.: “Befehl ‘unzip’ nicht gefunden” (‘unzip’ command not found)
  3. but pull down menu → ‘open’ installs the app.

After a few seconds there is a message ‘installation successful’ on the top of the screen.
And then the Android app really starts and works!

All this on a fresh flashed system, not on an updated one.

You are aware that you have to manually install the Android App Support from Store?
There were some mentions about people trying to install ancient APKs from Store before the Android App Support, which made things not want to work at all. Some sort of uninstall was enough - i don’t quite recall. But search the forum (related to Xperia 10 II launch) and you shall find.

Thanks. I guess last time I did it on autopilot, as I didn’t remember installing it manually. At this time, I am in dialog with Jolla support about registering my phone or whatever it is they need to do to get the Android runtime to appear in my Jolla store. The problem being that I had a Sony Xperia ii with Sailfish X installed on it, but needed Google Pay services for a trip. I flashed Android 11 over Sailfish on that phone and have since purchased another Xperia 10 ii that I can dedicate to SFOS.

Thanks. I still don’t have Android runtime installed, so that appears the reason for my issues. I am in dialog with Jolla.

Thanks for all of the helpfull replies. Both of my issues have now been sorted with the transfer of my Sailfish X license to my new Sony Xperia 10 ii phone.

1 Like

Transfer of a Jolla licence to another phone??

I always thought this is not supported by Jolla and therefore impossible…
How did you manage this?

Oh, I didn’t realize that this was an issue. I just contacted Jolla Care and told them the truth, that I had needed to use Google Pay services when I was was on a trip and had therefore re-flashed the phone with Android 11. Since then, I have purchased on extra phone dedicated to Sailfish X and that I hoped over time, i will be able to get wean away from the Google dependency, by using Sailfish X on a more regular basis.

That was always possible (due to courtesy of Jolla) from a device to another device on the same account and same device model series.