Jolla 1 boot images

Hello! Recently i’ve bought Jolla 1 (JP-1301) “for spare parts” even wtih original box and few back covers.

However, phone wasn’t booting, even in recovery mode. But it’s successfuly booting into fastboot. I’m suspecting that previous owner was bricked boot or recovery partition while experimenting on it.

I’ve got big experience in Andorid phones modding, and now i’m going to try Jolla as main phone. So, as i can see, Jolla itself isn’t providing any full imges to flash Jolla-1, so may be someone can backup first partitions using recovery mode and upload somewhere?

Fastboot flashing links on maemo forums are dead :frowning: But if anyone got backup - it would be nice, if you will reupload them :slight_smile: Thanks and appreciate for any answer!

It would be nice if someone can reupload images from here:

Is the Bootloader unlocked?

No, but it shouldn’t be problem to flash official images?

No you cant flash jolla 1 without opening bootloader.
When the bootloader is locked the prev. owner cant bricked boot Partition in my opinion.

When recovery mode is not working i think emmc is dying… :frowning:

Here is a tutorial to enter recovery mode

Hm, yep, it can be eMMC too. Thanks.


I´m new to sailfish os and I bought an Jolla phone but when I tried to start it it was stuck an didint go past the Jolla logo. I tried to do a factory reset with Windows and Putty but nothing happens. I get in to recovery mode and when I try the reset menu i doesnt work. Im not wery skilful with programing and technical stuff so I would appriciate any help I could get. I get a message that says something like:

ERROR: accessing `/mnt/@´
(ERROR) While deleting old user data!

Is there anything I can do to get in in working state?

Thanks in advance


But why. It is 10 years old (with specs to match) and 3 years out of support.

1 Like