Hi there.

Recently I switched from XA2 to XA2 Plus mostly because of ram. I find older SFOS supported devices suits me better. Doesnt really matter.

On regular XA2 I use polish delivery company app called InPost Mobile (Through app support) It requiers google services but wokred with with MicroG. It had android 10 support

I installed the same app on XA2 Plus. There is newer app support, android 11. When I try to register this app it reqiuers the phone numer. When I gave one it reports error as shown below

Is this fixable? Maybe Im missing something? App is installed through aurora store (The only way it works without giving “no google servies availabe” error)

Im all about alternatives but there is non for SFOS. This app is one of the last thing I need to reach my “perfect setup”

The Exception basically says that it tries to communicate with something that isn’t available. Have you tried it with microG? Is it the same version of the app on both phones?

I have microg installed and working. Without microg app will start, say it needs google play and that’s it. With microg working Im able to take few steps forward until it asks for my phone numer to register. On my previous XA2 this step was successful.

I had older version of this app on previous XA2, but I also downgraded it on my current XA2 Plus with no result.

XA2 Had older version of SFOS and android 10 support.
My current XA2 Plus works wirh SFOS and android 11 support.

I don’t think it has something to do with the newer Android version, since I don’t think the newer version (which is already 2 generations old) would remove something that now throws a IOException with SERVICE_NOT_AVAILABLE.

Have you tried upgrading your older XA2 to the same version of SFOS? (If that is possible) .
It would be interesting to know if it stops working on the other phone too.

Unfortunetly no, old XA2 was falling apart and I ask Jolla to move licence to new XA2 Plus.
It’s possible to boot old XA2 but without app support it’s not possible to try the theory

Did somebody face similar problem in different circumstances?

Maybe you can backup your previous settings and copy them over to the new phone?

How can I do that?
If any, Im not sure if old phone wasn’t reflashed at some point

I can confirm that same app works just fine on Xperia 10 III…
There must be some problems with os on my XA2 Plus. Anyway It’s going to be flashed soon

And can confirm that freshly installed SFOS on XA2 Plus problem persist
Nobody really faced this problem before? Seems to be related to java :slight_smile:
And it looks like a problem within android support…