Is the Sailfish Shop broken?


I am quite confused as I am currently not able to buy a new Sailfish license. I am Jolla-user since the beginning and acquired a few licenses already in the past. But I am currently unable to use the Jolla shop, as I am always getting the “Sorry, not available in your country” message. As I am based in Germany and tried different browsers on different devices (notebooks as well as my Xperia XA2), I am quite unsure if it’s just me or if there’s an issue at the Jolla shop.

Can someone please give me a hint, if there is really an issue to access the store from “my country”?


1 Like

I can login to the shop, choose a device (tried 10III), click buy, come to the page to select country (Austria selected), blue ‘BUY’ button is visible. (test aborted at this point)

1 Like

Hello Seven.of.nine,

Thank you very much. I just realized that indeed it seems to be a browser-related. Maybe I have to many data protection restrictions installed (uBlock, noScript).

Best regards

I’ve tried with three different browsers now - linux and android - and it’s always the same: " Sorry, not available in your country". So I guess they don’t like Austria … :wink:

Sailfish X is currently available in the countries of the European Union, UK, Norway and Switzerland

Since Austria and Germany are member states I guess the geoblock needs to be adjusted.

Short said; the RIPE database need to be synced or updated.

uBlock and noScript is not the factor here.