IPv4 mobile data connection not possible

yeah, i still only get a IPv6 too, but mobile data works for me; with the .68 it haven’t.

I might be suffering the same problem. I too can’t get an IPv4 connection when the phone is set to dual and this started happening sometime this spring after I did an update. (I guess
It also happens on my XA2, BTW.

My experience

In slot 1 : SimCard Orange France / No IPV4
in slot 2 : Same sim Card / IPv4 connexion OK (and so hotspot too)

Same experience for me with the same provider.

really hoping we get 4.5 soon with a load of fixes for these mobile data problems, as talkmobile is telling me that they’re switiching off 3G in the new year and that makes my XA2 a tablet, not a phone.

i’ve done my bit; bought the 10iii and a SFOS licence…

1 Like

oh, so are you saying that just swapping the SIM card and putting it in slot 2 would solve the issue?

For some people this worked, so i would give it a try.

Yes! Just tried it and i can confirm it works! Thanks.

They must be kidding… swapped sims: sim 1 lidl connect (DE), sim 2 ja mobil (congstar/t-mobile DE) now sim2 hotspot is working IPv4 is going to the clients in the WLAN.



(Now i “just” have to swap sims if I want to use the data connection from the other one… )

Edit: Downside: VOLTE / 4G calling(beta) is not working anymore… - “not registered” and blinking all the time in the mobile network menu

lol, nice find!
but not a solution. i hope this helps jolla to fix the bug!

1 Like

Confirming IPv4 working on sim slot 2 (not on slot 1), hotspot works but no VOLTE :+1: - and obviously no sd-card anymore.

I did switch back to sim1 - cause on sim2 the LTE connection did not work all the time, very often the connection was marked “restricted connection” and i had no internet at all.
Back at slot sim1 volte and the connection is working fine again.

However, i try to disable sim slot1, in configuration and then the connection data with the sim card in slot2 failed … Very strange bug

and … MMS don’t work with the SIM card in slot2

I have to correct what i said in my post from 1. Aug. 2022 in this thread.
Like others already stated without ipv4 mobile connection no internet connection sharing is possible and some apps don’t work like the bicycle sharing app for hamburg stadtrad on Xperia 10 iv.

This problems did not occur on my Xperia 10 iii (4.4.0 not yet tested).

xperia 10 iv? surely you meant 10iii?

Hey, yes, sorry, i messed up the version numbers. I was talking about ii and iii.

Right now i have two sim cards, one t-mobile and one simOn mobile (both german 900 MHZ D net).

If i insert them in my Xperia 10 ii (2) i get an IPV4 address assigned over mobile network (see the attachments with “ii” in their names if you like). Software version on ii right now is but i’m 97.5% sure that PV4 assignment worked on all previous versions as well.

On my Xperia 10 iii (3) i get no (!) IPV4 address assigned over mobile network (see the attachments with “iii” in their names if you like) (version but didn’t work on (and neither).

On my Xperia XA2 i’m quite sure i got IPV4 addresses assigned.

So for me it’s evident that only the Xperia 10 iii (3) is missing an IPV4 address assignment.

P.S.: if i got it right at the passed IRC meeting there will be a new software version in January and it will include some rework on connection establishing / switching. Maybe this topic gets fixed by this update, too. But i’m not sure if i’ve understood it right.

1 Like

Apparently SFOS 4.5 provides more problems with the hot-spot. Previously, I only had problems with the Xperia 10 iii and Congstar SIM, while Xperia 10 iii with Vodafone (Germany) SIM was giving me Internet access via a tethered connection.

Now I observe the same problems I previously only had with Congstar also with Vodafone SIM in the Xperia 10 iii.

I haven’t checked with the Xperia 10ii yet but will do so soon. Until now (i.e. until SFOS 4.4), I had now problems with the Xperia 10ii and any SIM


Data works as before for me with Iliad. I did not try with Vodafone Italy yet.


I still have the problem that IP4 and especially hotspot does not work