Internet works with Sailfish Browser but not with Brave

Brave shows “No internet connection” (with Wifi) but the Sailfish browser works fine. In Settings → WLAN it is shown: “Limited connectivity” (it is a connection where one was redirected to a site to a) fill in a phone number and then b) enter the received sms code.

It’s a XA2 phone (OS, check for updates works btw).

  • restarting the phone didn’t help
  • restarting Android subsystem didn’t help
  • (when switching to Mobile Data, Brave works)

According to some browsing here in the forum, I’m not the only one with “Wlan-Issues”. Is there anything I could do? – Frankly, this is a disaster.

1 Like

Further progress/notes:

  1. it was not only Brave but also other Android Apps, e.g. Threema which didn’t have network connection through Wifi

  2. I continued with the normal (Sailfish) browser. After maybe an hour the online connection stopped and instead of the desired webpage a network login page appeared where I had to enter my phone number and then got an sms with access code. It worked again afterwards

  3. Brave didn’t work right away. But after stopping the Android emulator and restarting Brave I had again network connection through Wlan with Brave. Thus all well again (for now;)

My interpretation is that on the Android side the Wifi connection expired earlier than on the Sailfish side. But there was no possibility to regain/reactivate the Wifi connection from Android (emulated) apps. – Should this be reported as a bug and/or problem?

Waze has a similar problem. If I make/receive a call while using Waze, since my provider only supports 2G and 4G, data will not be available and Waze will report connection unavailable forever, even after the end of the call, until restarted.

Probably has something to do with ipv6 on your LAN.

I’m also curious if it’s ipv6 related?

How could I find out if it is IP v6 related?

You could try to disable it temporarily in your router. Really solving it could be difficult, but it it’s related then you’ll at least know it for sure.
I had issues like that before on a different router setup.

1 Like

You can also see what kind of IP you have in the Developer tool, turn on SSH and you should see an IP address.

1 Like

I have the same problem occasionally, Sony Xperia X10 II, dual sim model, DNA prepaid (mobile data disabled), using only WLAN, Struven ketju IPv6 is disabled in my wireless router.

Sailfish Browser works without issue, ‘Sailfish OS updates’ complain about connectivity and journalctl show this line (relevant or not):

Apr 13 20:43:17 Xperia10II-DualSIM connmand[1045]: Failed to find URL:

Restarting networking and/or rebooting the phone may work or not, usually not with the first try. If no corrective action is taken, the problem stays active.

What exactly does “limited connectivity” mean, what specifically is needed for connman to come to this conclusion? How to debug this?

Connman checks the connectivity by trying to get the url you see in the journal. If it fails it gives the “limited connectivity” status.

1 Like

I think it’s when Connman can’t get a DNS server address from internet provider.

1 Like

Indeed changing the DNS manually usually fixes this bug.At least in my case ( XPERIA 10)

Don’t see if someone metion it already. The internet connection for android apps (And only that) often fail, especially when switching to wifi from mobile and Vice Versa. It’s well known bug and it has been around since I don’t remember. I don’t think that Jolla ever tried to fix that :confused:

Best way is to restart network in sailflish utilities or reboot.

Never faced that, in my case only app support sufferts from loss of internet conection, refreshing services often help, reboot always help

It’s better to find what the problem is, but unusal problems like this are often solved with re-flashing

On my new 10 III I had repeatedly expirenced sudden lost of gps signal that no one could properly diagnose or solve. After flashing it once agian gps work perfectly

As suggested by previous posters, it is a DNS problem of sorts.

I dug up an extra Access Point, connected that to a switch that can mirror ports, connected the switch to my wireless router, connected a Linux machine to the switch mirroring port, and fired up Wireshark.

What happens in the unsuccessful case is that the phone does not try to ask the IP address for with a DNS query, but tries to connect with TCP to port 80 of and the destination Ethernet MAC address is my wireless router’s. Should anything with a destination IP of even leave the phone?

The capture shows that the WPAD protocol is restarted just prior the botched TCP connect. In the successful case, the WPAD protocol is run only once.