Installing SDK on Windows : bash.exe cannot find ssh-keygen.exe

Hi, I am trying to install the SDK on Windows.
I have Git for Windows installed, but I use Windows’ OpenSSH.

During installation it asks for the location of bash.exe, and then complains that ssh-keygen.exe was not found in the bash installation.
Tried selection either C:/Windows/System32/bash.exe, or C:/Program Files/Git/bin/bash.exe, but both with the same error.

ssh-keygen.exe (from openssh shipped in Windows, not Git’s one), is available on the system, and I would like to keep using it (so not installing other ssh apps).

Any idea how to continue installation of the SDK ?

I would really recommend you to use the true MSYS2 environment. It is more reliable and more powerful option at the same time. Check Installation | Sailfish OS Documentation. ssh-keygen.exe is not the only dependency, just the first one the installer failed to look up.


Thanks. Yes, I saw the documentation and I am hesitant to install it to not clutter my device.

I install it, and the installation went fine. Although openssh isn’t installed by default with msys2, I have to pacman it.

Strange, this reminds me of Maybe you checked before you installed git?

I didn’t install git in msys2. I installed openssh in msys2, and installation went fine after that.

That’s the issue then - the Installation | Sailfish OS Documentation instruct you to install base-devel and git for a reason :slight_smile:

1 Like

Not sure why, but I’m failing to connect to the build engine with a timeout error (from the IDE or the terminal).
I also tried all uninstalling, then reinstall following exactly the instructions but with the same error.
The emulator also shows a blank black window, even though I have virtualization enabled and other VM guests (such as Ubuntu) work correctly in virtualbox.

There have been issues with recent VirtualBox releases on Windows. 6.1.24 works well for me - please try downgrading to that version.

1 Like

Thanks, that was it ! :slight_smile:
Downgraded and all is good now, both build engine and emulator working great.

Great :slight_smile: I would consider marking the very first reply as the solution (Installing SDK on Windows : bash.exe cannot find ssh-keygen.exe - #2 by martyone). The one you marked is a bit unrelated to your original question.