Installing SDK on windows 11

i thought i will start with app development again, maybe contribute to tidal app.
however my last laptops were linux.
the current one is windows 11.

i have tried to install the online installer, failed due to missing bash
have installed msys2 and after reboot was able to pass that dialog
then failed due to : no connection to build vm (i am using vm box) at 75% of installation progress.

the next trial failed to download the packages or better failed in extracting them

on the next trial i did download the 1.9 GB offline package.
and now i am watching the offline installer downloading packages.

A) is that normal ?

B) is it recommended to manually start vmbox before starting the installation ?

C) should i run the setup as admin ?

D) i always get this message in the installer : sfdk.emulator: [C] Failed to load system-wide emulators configuration

rather frustrating experience on windows so far.

any hints are welcome
thanks !

Solution: VirtualBox + any Linux distribution

4th trial with offline package, running sdk as admin, and installing only one target did work

I’m glad you successfully got the SDK installed @pawel.spoon. As per your request I’m closing and archiving the topic.