Installing SailfishOS on a refurbished/second hand Xperia 10 III

Hello folks,
could there be any problems installing SailfishOS on a refurbished or second hand Xperia 10 III, for example if it was simlocked before in its lifetime?

1 Like

In any cases, you may want to check if the bootloader can be unlocked by composing this code in the phone (at the place of a normal phone number): star#star#7378423#star#star
See here : Checklist for Sailfish OS | Sailfish OS Documentation
I don’t think that ex-simlock would bother, but not 100% sure.


This is exactly how I purchased my Xperia 10 III - of course, you need to buy it on the condition that it isn’t SIM locked and that the Bootloader can be unlocked. I believe the latter is almost always true anyway. There may be local legislation that forbids operators from doing the former, depending on where you are.
The easiest thing is to ask the seller, or buy from someone who can guarantee this outright.
Good luck!


after a simlock it could be that the bootloader unlock isn’t allowed. in that case one can try to do another simunlock, that costs about 10€ or 20€ for the credits and with those you can use the simunlock tool to make the unlock yourself, i’m not sure about the price, and then it hopefully says bootloader unlock allowed afterwards

Is it even legally possible to simlock an X10III, given that it is in Sony’s open device program? I don’t know, just a thought.

Thanks for your reply. I’m from Germany.

I also got my 10iii refurbished (as my XA2 before that), shipped from Germany to my place southern Europe. The website I got it from did say it was SIM unlocked. I thought unlocking would be standard for refurbished items specially because it’s the only way to sell cross-border (operators are different). If unsure of the phone condition, you could ask your phone operator if they are able to unlock a refurbished Android phone and how much they charge for the service.

I received my refurbished Xperia 10 III today, checked bootloader status and it says unlock allowed. Only problem is that the phone has been delivered with Android 13. So now I have to follow this guide I guess?

You have first to unlock the bootloader and then follow the guide you mentionned.


Whilst that link has instructions for downgrading via Emma, this one is better overall, assuming you have Windows.

Note, if your cable works with Emma, it should work for the rest of the process too.


Arch Linux is running here but I also have a Windows 10 computer as backup which I almost never use. Now it’s time to wake it up I guess cause the Emma tool only runs on Windows.

A virtual machine could be an option (e.g. VirtualBox).

Worked fine on my X10III, but not on my old X.

I managed to unlock the bootloader and to flash Android 11 onto my Xperia 10 III. Then mobile data was not working any more, it had worked in Android 13 before. I found out that there is no APN set. I restarted the phone, reset APN to default and reset network settings, nothing helped. So I found some APN settings on a third party website and after entering those mobile data works again.
I’ll do some further tests before flashing SailfishOS.
Could this occurrence make any trouble in SailfishOS later?

Yup, happens to me with Smarty/UK. Depends on the network.
To be honest, I can’t even make roaming work these days :frowning: