Install SFOS on an Xperia X (5121) - bootloaders and S1Boot Fastboot Q's?

Tring to install SFOS 4.1 on an old Xperia X using Win10 (19042), using the following instructions:

Q1 - "OPTION 1: If your device has its bootloader locked:"
Instructions are effectively: update your device, and don’t worry about whether the bootloader is locked, then move onto step 2…
Pretty sure when I installed SFOS 3.2 on an XA2 Plus using Win7 a few years back i had to unlock the bootloader via some code on Sony’s website.
What is going on here?

Q2 - " 2.4 Find the ‘S1Boot Fastboot’ device in the tree. If it is not correctly installed, it will show a warning sign."
Instructions are effectively: go find the driver, and when you do find it update it manually using the extracted files from the driver zip you previously downloaded…
… but i’m not seeing a “S1Boot Fastboot” listed in Device Manager to update.
What is going on here?

Cheers

You still need to unlock bootloader if you scroll down to Q4. Your Xperia X was in “bootloader mode” with “blue LED” when trying to load appropriate driver? Another trick used to be to install “Xperia Companion” from Sony which will install needed drivers.

I am told it’s also now possible to flash sfos to an xperia x using the ubports installer Sony Xperia X (F5121 & F5122) • Ubuntu Touch • Linux Phone I’ve never tried it but it’s worth a try if you’re having trouble

Your phone will likely not show Android updates if it is unlocked, so thus updating Android is split in Option 1 and Option 2.
Unlocking comes in step 4.

You misunderstand. If it shows “S1Boot Fastboot” (at least without a warning sign), the correct driver is installed. If it either does not show that name, or shows a warning sign, you replace the driver.
I suggest you try using fastboot with any driver that claims to be correct before trying to replace it… but still.

Just trust the instructions :slight_smile:

Thank you both, past the initial two questions.

Now a problem with stage 4:

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> ./fastboot.exe -i 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxxxxxx>
C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43\fastboot.exe: unknown option -- i

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> .\fastboot.exe devices -i 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxxxxxx>
C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43\fastboot.exe: unknown option -- i

the forum seems to be stripping out the unlock code part of the command text, but it was there (obfuscated).

are you supposed to keep the chevron brackets when you add the unlock code in, or, strip them out?

either way, i get the “unknown command” response, and restrating the device does not indicate the device now has an unlocked bootloader as is the case with my XA2…

I stopped using Widows over 10 years ago, and especially with the forum eating parts of your command i can’t really say much.
(use `backticks` or the formatting menu to get proper code formatting)
But maybe try with CMD?

Ah, thanks. Reformatted the text ^above^.

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> ./fastboot.exe -i 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxxxxxx>
C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43\fastboot.exe: unknown option -- i

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> .\fastboot.exe devices -i 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxxxxxx>
C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43\fastboot.exe: unknown option -- i

Is there anything wrong with the structure of the commands on Win10 (19042), using Powershell?

Can I try asking this another way?

Notes says this:

NOTE 1: Windows 10 PowerShell requires the commands in the following way, e.g. “.\fastboot.exe devices”

b) If you use the Windows PowerShell:
./fastboot.exe -i 0x0fce oem unlock 0x<insert your unlock code>
NOTE: If the commands above should fail with an error message about the “-i” option, please try using the shorter command variants below:
b) If you use the Windows PowerShell:
./fastboot.exe oem unlock 0x<insert your unlock code>

I have tried all three and none seem to work…?

Seems it is .\ for PowerShell, and it also seems you might need to drop the -i.

What happens with:
.\fastboot.exe oem unlock 0x<insert your unlock code>
or
.\fastboot.exe devices

If this still doesn’t work i definitely suggest you try CMD.

ooh, thanks. did i do it?

I’m booting up the device but there is no warning about unlocked bootloaders as is the case with my XA2 Plus…

and the succeeding part of the install fails as the device is not unlocked.
it is the least discouraging message so far…

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> .\fastboot.exe devices oem unlock 0x<xxxxxxxxxxxxxxxxxxxxxxxxxxx>
CC514A0MGS      fastboot
PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43>

Also tried in CMD to no effect:

C:\Windows\system32>cd C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43

C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43>fastboot -i 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxx>
The syntax of the command is incorrect.

C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43>fastboot 0x0fce oem unlock 0x<xxxxxxxxxxxxxxxx>
The syntax of the command is incorrect.

No, that was just to check that you could run fastboot at all.
oem (and unlock underneath it is) a different sub-command, not related to devices.

If you drop the -i flag/switch, you also have to drop its data (0xfce).

So this should work for you then…

Obviously without any <>, just your actual code.

Thanks, that did it i believe:

PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43> .\fastboot.exe oem unlock 0xXXXXXXXXXXXXXXX
                                                   OKAY [  1.394s]
Finished. Total time: 1.394s
PS C:\Users\Me\Downloads\Sailfish_OS-Jolla-4.1.0.24-f5121-0.2.2.43>

p.s. the trick was removing the chevron brackets. :wink:

SFOS 4.1 installed successfully.
My thanks to all involved.