I4293 Unable to shutdown device

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.45
HARDWARE (Jolla1, Tablet, XA2,…): i4293 XPeria 10+ 6MB
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): Used to be intermittent in previous release, now persistent

DESCRIPTION:

Device reboots after shutdown.

PRECONDITIONS:

From either encryption, lock or home screen.

STEPS TO REPRODUCE:

  1. Press hardware button shortly for top menu shutdown option OR
  2. Press hardware button for some time
  3. Device says good bye, red LED turns on

EXPECTED RESULT:

Device shutdown.

ACTUAL RESULT:

After prolonged red LED, LED flashes shortly green/red and device reboots.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

1 Like

Yeah, the same happened on my X10. To me only thing that worked was flashing latest Android and then back to Sailfish. I am not sure why, but I think it is caused by some app, maybe Android support?

1 Like

My Xperia Z3 Compact Tablet does the same; it reboots instead of powering off.

1 Like

Temporary solution to the rescue to force shutdown when needed:


In the Restart section, expand “To force the device to restart or shut down” and follow instructions.
3 Likes

Still not solved in 4.0.1.48 :disappointed_relieved:

This works, but it is like unplugging your desktop everytime you want to shut it off. Anyone figured out how to fix this issue? I even tried reflashing 4.0.1.48, but sadly it is worse than on 3.4 :cry:

1 Like

Since upgrade to SFOS 4.x from 3.x my Sony Xperia X device won’t powerdown or reboot any more. If I use one of the both butons from the top menu which is showing after pressing 3sec the power button the screen will be going black after 2 sec but the system will not power down nor reboot. It looks like it goes only in the the device locking state.
I used the console tool with devel-su to shutdown the device but than got other problems where the system won’t boot up any more (black screen problem).

I just deactivated the developer mode and I could shut down my device (xperia x) again.
Hopefully it works for you too!