I have just left sailfish os

Hi folks,
yesterday evening, after a last desperate SF re-installation from scratch, I flashed back to android my Sony XA2 plus. I’m not happy but all my authentication apps (i.e. banks, public administration) where stuck. Before the upgrade to SF 4.1 everything was working but since that moment where running only whatsapp, telegram and skype. Nice and useful apps, but not fundamental as the ones that I mentioned.

My experience with SF has started in November 2018 and it was not so bad: I agreed to have a partial-working phone (i.e. often, after a reboot, audio in phone calls was not working) with more privacy for me and my contacs but only if the really useful android apps had worked. Android is a standard “de facto” so it cannot be ignored: I think that there is a big difference between being not mainstream and being self-harming.

For the future I’ll be glad to revert my phone to SF but at least with these features:

  1. android working with all apps (this means gapps compatibility)
  2. documented tools and procedures for debugging what’s going on and eventually asking for bug fixing
  3. improve the web browser: it’s not possible that I cannot click on “agree” pop-up when I’m using google search engine
  4. (optional) implementing the filter on contacts: I would like to choose which of them can be exposed on android apps

Thanks for the support you gave me during these two and half years.
Good luck,


Tell Google to change their policies, then. Jolla is legally forbidden from adding GApps if their devices don’t run Google’s Android.

  1. Ermm, this simply cannot and will not happen.
  2. Agreed, the browser is much better, certainly coming from Jolla1 to Xperia 10ii it is noticeable.

However, this is NOT obvious at first or indeed many times after and has frustrated me on many occasions!, . . .

The ‘agree’ pop up is totally clickable, but first you must tap the physical scroll bar on the right side of that pop-up, once you have tapped your way to the bottom of the agreement, tapping ‘AGREE’ is responsive first time.

1 Like

or even I can complain with developers that use gapps…

Seriously: the android compatibility it’s a major problem and I didn’t found any solution with microG or similar. After the GDPR introduction almost every authentication system uses an app running only on a mobile phone, so this issue it’s really blocking. In example: without authentication I cannot present my individual income tax declaration or I cannot login into my bank account.

I really would like to know how other SF users have solved this problem.

I have no problem whatsoever in running Android apps on my XA2, including apps using authentication, with the exception of a) no access to Bluetooth and b) some apps that are declared “not compatible” for some reason I cannot know (eg Vodafone Italy app). I am using the latest MicroG for GApps compatibility.

Did you try also with PosteID?

Yes, PosteID works fine (it complains about the device being rooted but works nonetheless), so does IO and the banking apps of IWBank and Webank (except that IWBank refuses to generate tokens because it does not see the screen lock, but it’s because the app is badly written).

1 Like

Did you manage to install microG or not?
If not, find a suitable thread and just ask.

Also, please write your politicians and MEPs about that platform dependence by lazy companies is keeping you from using your identity online. They likely haven’t even thought about it.


LOL… The Italian Covid tracking app (“Immuni”) does not even run on Huawei phones because the developers wrote it to depend on Google services!

I tried with a SF install from scratch and, off course, I installed microG but posteID was still complaining about network and also if I gave it full access to the network it wasn’t working.

Hi Giorgio, I used PosteID on sfos a couple of years ago. Now I just use Bancoposta app and that’s fine for my needs. Also the public administration app Io works fine…without microG I think.

The gapps caompatibilty can easily be fixed with microg. Once I installed it, everything google related worked fine, including maps and such.

How long ago? Which version of MicroG? I seem to remember something like that for a while some time ago but now it works.

I did the last trial on monday 22 of August: last version of SF, current stable of microG (0.2.22) and last version of posteID. With the previous version of SF (3.4) everything was working properly.

P.S. I’m sorry: I posted twice because I forgot to click on “reply”.

I would never ever do tax declaration or banking on a mobile phone, no matter what device it is. But of course you are free to do and let google track every aspect of your life…


it is an authentication system: there is an app that authenticate your work session on pc. Useful, smart or not, I cannot avoid this so I need these apps.


those apps becoming mandatory is aweful. Maybe at least for banking you can switch to CardTAN. For taxes I use the good old letter or I am lucky that I can authentificate myself with my medical ecard reader I need in my job.
Or use an old cheap, crappy android phone just for that.


Giorgio I’ve just downloaded PosteID on my xz2c, latest sfos 4.1…I have microG with spoofing enabled. It works ok. I presume the Io app works too, I don’t need it yet.