I can't view video received in mms

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.2.0.21
HARDWARE (XA2, X10, X10 II, …): Xperia XA2 Plus
UI LANGUAGE: Swedish

DESCRIPTION:

I receive some videos in a mms a it’s a .3gp video (3GPP) but i can’t view it.
If i chose play in the mms it opens Gallery app and then it goes black and i can’t even see the controls but i can swipe down to close the video.
If i run file on it then it outputs “ISO Media, MPEG v4 system, 3GPP” and the files was sent from an iphone.
If i copy the file from commhistory to Downloads then i can open and see the video with gallery but it complains about missing Adaptive Multi Rate (AMR) decoder so there is no sound.

PRECONDITIONS:

Recieve an 3gp video in a mms
I only tried with a mms video from a iphone

STEPS TO REPRODUCE:

  1. Click on the video in the mms
  2. Click on the video again

EXPECTED RESULT:

The gallery app should play the video with sound

ACTUAL RESULT:

The gallery app opens the video and the screen turns black.
It doesn’t show the video nor plays the sound and there are no controls or video progress bar even if i touch the screen.
I can swipe down to kill the video and remain in the gallery app

ADDITIONAL INFORMATION:

If i copy the file from commhistory to Downloads then i can open and see the video with gallery but it complains about missing Adaptive Multi Rate (AMR) decoder so there is no sound.

The missing sound seem to be mentioned in this post.

5 Likes

Same issue on my XA2. This is annoying since the phone is used by my son and some of his friends can’t read yet - so they send audio clips. Which the phone doesn’t play.

It happened to me too. Where I can find the MMS video file to see it’s format?

What about
~/.local/share/commhistory/data/

and then in one of the subdirs xxxx?

1 Like

Thx. Yeah, there it is. File browser app even show picture preview and shows:
Error playing video.

Adptive Multi Rate (AMR) decoder

Me neither. I’m on Xperia X with SFOS 4.3. I shot a video with my new Xperia 10 III with Android, sent it to my Xperia X as mms (BTW, that was not easy to figure out how to do in Android!). But when I try to view it in SFOS, I only get ‘Could not load video’ (Swe: “Videon kunde inte laddas in”) in the image/video app. The video is *.mp4, about 30 seconds long, 58 Mb, 1920x1080 (2.1MP).

Now i get the same error message “Videon kunde inte laddas in” when i try to open it with Gallery.
But now i can choose to open it with another application like VLC android app, it works and starts to play sound, but for some reason i need to swipe to the side to miniaturize the app and then choose that miniaturized app for it to show the video or it’s all black.
It’s not solved yet but at least it’s easier to work around the problem.

first you need amr codecs: e.g. from here:
https://ftp.uni-erlangen.de/packman/suse/openSUSE_Leap_15.2/Essentials/armv7hl/

you will need https://ftp.uni-erlangen.de/packman/suse/openSUSE_Leap_15.2/Essentials/armv7hl/libopencore-amrnb0-0.1.5-pm152.1.4.armv7hl.rpm and https://ftp.uni-erlangen.de/packman/suse/openSUSE_Leap_15.2/Essentials/armv7hl/libopencore-amrwb0-0.1.5-pm152.1.4.armv7hl.rpm

then you need gstreamer-plugins-ugly with amr support enabled e.g. from here Gstreamer Plugins Ugly 1.16.3 (JollaPhone & X & XA2) | OpenRepos.net — Community Repository System