I can’t get the VPN to work

Hi, I tried to run sailfish OS VPN with proton VPN files. But when I try to connect the VPN flashes continuously without ever connecting.
I use xperia 10 III with
With the same file it worked with my XA2+.
Is it a bug?
Has anyone managed to run the VPN on the xperia 10III?
If so how?
Thank you

Gd morning! Xperia 10 III running Vanha Rauma here.

I’ve been using the free service of ProtonVPN for quite some time now (~3 months), and works fine from the very beginning.

After importing the settings from the files provided by ProtonVPN (OpenVPN), it initially asked for credentials, and that was it.

I use some OpenVPN set ups on my 10 III, Importing the certs, key and ovpn works.

Maybe a test with another provider might help.

Maybe you do not have IPv4? Depending of your IP, your phone maybe IPv6 only despite the Dual IPv4/6 setting on the phone. Normal browsing, e-mails etc. works. Other symptoms of missing IPv4 are a non working WiFi hotspot. If the VPN file contains server’s IPv4 address, that would not resolve. I resolved the FQN name of the server’s IPv4 address on my computer and put the FQN (name, not IP-address) in the VPN server description file (not Proton, in my case). With that the VPN is working again, see my somewhat lengthy explanation in the above thread.

Thank you.
My FAI (french Bouygues telecom) only provides IPV6 addresses.
I change VPN provider for an other one who work with IPV6 addresses (mulvad)
Now VPN works (not for android bowser but I think that is a know bug)

Have you done anything special to make MullvadVPN work?

I myself use MullvadVPN, I have imported a .ovpn-file when I bought my Xperia 10 III which works, but now when I import anorther file (to have two servers) it doesn’t work, it always says “Problem with the connection” (translated to english). I don’t know what I am doing wrong, it is the same company is the other VPN I have already configured (although I don’t remember if I made some specific changes last time). Interestingly, I have the same error when using WireGuard with the WireGuard Plugin.

My Mullvad VPN only work with Mobile Data …
Wifi connection cant hide my ip…

Sorry in english it’s better

I downloaded the android file and renamed the file to remove the “. txt”.
My xperia 10III is configured in IPV6 only.
After that, I add my login and password.
I have 2 different servers.

For information, I cannot get the wiregard files to work.