I am having trouble flashing Android back to Xperia 10 III

I am having trouble flashing Android back to Xperia 10 III.

With no complications, I have installed Sailfish OS on my Xperia 10 III using MacOS. Now I want to revert my phone back to Android for a bit. I found this guide (Reinstalling Sailfish OS | Sailfish OS Documentation) and got access to a Windows computer. Unfortunately, when I try to hold the volume down button and connect the USB cable, the led flashes red, and the phone boots to the charging screen. Please help me to solve this issue.

Have you tried holding down vol up/down + power button until feel 3 vibrations then release?

Thanks for your reply. Should I do it with USB cable connected?

No. (post must be 20 chars at least)

Thanks. I will try now

So I have tried it, and it didn’t help. I held those three buttons, waited for three vibrations and connected the USB cable. It still boots into the battery screen. I need the LED to turn green so I can connect it to Emma

I don’t know if there are differences between X10 and X10-III regarding this. But on the X10 its

  1. Power down with Vol up until 3 vibrations (without cable)
  2. (when device is fully powered down) Hold Vol.up
  3. connect cable

naturally computer has to be ready to flash and cable connected to computer.

exactly, connect the phone to your pc and while pressing down volume to have green led. I do that for my 10.
On 10 III you can even re lock the bootloader to not have the lock advertence when you turn the phone on.

Thank you both for your help. It just worked :blush: