How to run file browser root in x10 II with 4.2 to change something in a file

How I can use file browser in root , cause I cant do anything in it.

Does it not function properly even in home directory, or are you trying to do things that require root?
It’s possible to start it from command line with ‘su’, (doesn’t work with ‘devel-su’ for whatever reason), but if it’s not doing what it’s normally supposed to do, that’s probably not the best approach…

I wanna write 2 lines in usr/share/lipstick/androidnotificationpriorities

At your own risk, (in terminal):

  • type ‘devel-su’, and then your password (get root prompt)
  • type ‘passwd’ and it will ask you for new password. Make it whatever you want (this won’t have any effect on your ‘devel-su’ password)
  • type ‘exit’ to get back to regular prompt
  • type ‘su’ and then enter your new password (get root prompt)
  • type ‘harbour-file-browser’

thanks, but how can to be use in the file browser app?

ok, get it. now I just miss how I can write some lines in the file

install an editor and do the same thing with that…

or use terminal:
'devel-su vi /usr/share/lipstick/androidnotificationpriorities

do the same ting with that?

with the editor
(instead of “harbour-file-browser” it’s “harbour-editor”)

1 Like

With the terminal doesnt allowed me to write more or delete nothing. is that normal?

vi is a program -
you have to use it by certain functions. There are other options, (nano, pico, emacs, etc), they all operate differently.

you can use gui editor if more comfortable

Sorry if I am to stupid, but it will be easier if I can see a step by step. I have just try again in the terminal, and I can write , but now I dont know how to keep it rewrite in it

with vi:

  • open the file, “vi (filename)”
  • press “i” (now you can change it)
  • make changes
  • press “:wq!” (without quotation marks)


1 Like


how should I press that?

Using the keyboard?

levone1 missed one step
before pressing :wq
you ned to leave edit mode by pressing ESC

Please see some vi example


@Levone1 thank you so much for your time and pacience.
I have manage to do it at the end.

I havent understand how to do it in terminal, I will try, cause I will like to know for the next time.

Thanks sooo much

so strange - I actually did type when I replied (carats and all), but somehow it disappeared when I clicked ‘post’…
I think it’s the old “presage deletes stuff yoy don’t want it to” bug. I’ll have to get around to filing that report someday …

it just happened again… I think this website is deleting my “escape” text… () It must be recognizing it as a command and getting null from it or something

test it:
type these symbols in order and try to post it:
<, e, s, c, >

Let’s see typing now,

within block quote (four blanks)


within code quote (‘text’)


yep, directly disapears, seems discourse interpretes it?