How to recover partition from phone with no touchscreen

My Xperia X no longer responds to touching the screen. I’ve tried switching screens with another device and the problem persists, indicating it’s on the motherboard not on the screen itself,
This means I cannot boot the device since I cannot enter the security code on booting.
I thought I should still be able to transfer the data partition (encrypted) to my desktop and decrypt it from there. I followed the directions to install TWRP to the recovery partition using fastboot. But when I try to boot I still get the security code prompt.
I tried using the ‘fastboot fetch’ command but received the following response:

fastboot: error: Unable to get max-fetch-size. Device does not support fetch command.

So now I’m wondering if there is any way at all to either boot my phone or access its partitions using adb or something similar.

Have you seen this guide: Recovery Mode | Sailfish OS Documentation ?

Maybe your USB cable or USB port is the problem.

1 Like

I didn’t realise you need to use a Sailfish recovery image. Once I knew that it was all pretty straightforward.