How to fix Gemini PDA device boot loop?

My Gemini PDA (SFOS 4) is in a boot loop, constantly rebooting.

Not sure what caused it. I have Defender installed (but encryption isn’t available on gemini), and had rebooted many times without issues. But haven’t reboot since the latest release yesterday.
Last thing I did before the boot loop, was trying to replace GCC files and libraries with the ones I took from Debian ARM in order to get an Ada compiler working on SailfishOS (gcc ada, gnat, etc.).
It’s after that, that I rebooted and get stuck with a boot loop.

I tried to reflash SFOS initially but couldn’t get it working (boot loop won’t let me connect correctly to the PC). Though I went into recovery and wipe flash and cache and all, and managed to reflash official Android 8.1 and it went well.
However, after that I flashed SailfishOS successfly, but upon the first boot it went into the same boot loop.

Anyone have any idea how to fix this ?

I might have found a bug in Kodi 4.0.1.48. Not sure why, but I reflashed the device with Sailfish X 3.4.0.24, and I could boot up correctly. However, flashing directly version 4 ends up in a boot loop.

1 Like

I updated Gemini from SFOS 3.4 to 4.0 OTA without any problems. Of course, I followed all the recommendations (uninstall conflicting Openrepos applications, including repositories, …).

Thanks. Yes, flashing 3.4 and OTA upgrade works (already tried it a couple of weeks ago). However, flashing directly 4 with the flash tool fails in booting (boot loop or now It’s stuck on the boot logo screen).

However, I found out I had my NVRAM is wiped or corrupted, as I couldn’t register my IMEI when logging to Jolla’s account in 3.4.
Restored it from backup with the flash tool, and then I tried reflashing all the SFOS 4 with the flash tool, and it went fine. So maybe that blocked booting on 4.

So to recap, as I have now things working well:

  • Got boot loop error first, maybe due to Defender app, or most probably to my tweaking with gcc files and libraries
  • Reflashed things and get stuck in boot loop, and somewhere during my multiple tries I wiped cache and data and NVRAM got wiped
  • Flashing 3.4 with NVRAM wiped works, but flashing 4 ends up in being stuck on the gemini boot logo/screen (the one with the penguin)
  • Restored NVRAM (with flash tool from gemini) and reflashed SFOS 4 and all is fine now

Would you do me a favor and check following command?
ls /usr/lib/systemd/system/sailfish-unlock-agent.service

If this file is present and you downloaded the v0.4.3 on Feb 24th before around 0700 UTC then it might be that defender was the culprit. :frowning:

If not (either file is not present or you downloaded after 0700 UTC) then Defender is absolutely innocent. :wink:

As I re-flashed everything, I can’t check what was before all that happened :frowning:

But I installed Defender today, and rebooted the device with no issues.
The file /usr/lib/systemd/system/sailfish-unlock-agent.service doesn’t exist on my system now.

1 Like

So let’ recap: Defender is not the bad guy!

Proven by:

Whereas fiddling with system libraries … :wink:

1 Like

Yes, the Gemini is my dev device for SFOS. Its purpose is to get its system librairies fiddled with :sweat_smile:

1 Like