How to change the telecom vendor / SIM card (SF 4.1)

I want to change the SIM card and the telecom vendor serving my Xperia 10 II, but find this difficult.

I only use one SIM card in the phone (in SIM 1 position). The SIM card that I want to change to has previously been used without problems by SF 4.1 in my former Xperia X.

Just turning off the 10 II phone and changing SIM card, made the phone identify the new card and the telco that has issued it. But that was as far towards the new telco as I came.

I then tried to reflash the phone with SF 4.1 with the new SIM card inserted. Going then to Settings-Mobile network displays relevant addresses for access points for mobile data and MMS, but I’m not allowed to select mobile data for internet access, as the name of the new telco and the “button” in front is greyed out. This of course is related to that further down on this page the identification of network in use just displays “Searching”. Deselecting “Select network automatically” gives some varying results (from the same physical position of the phone) as to how many networks are identified and which one is highlighted. I guess the latter is decided by which one comes out on top of the list - sometimes it’s “my new” network, sometimes any of the others. In all cases though, selecting “my” network that corresponds to the SIM, results in the message “There are problems with connecting” when the waiting indicator finishes, (which of course is also the result when selecting any of the other networks for which there are no corresponding SIMs in the phone).

I’ve tried repeatedly to switch to flight mode with a pause and then back, as well as to turn the phone fully off. During all the time spent trying to overcome the problem, the telco vendor in question has been operating normally and connects with other phones in same area. SF gives no further information of the closer nature of problems encountered, and I’m lost.

But I guess/hope there are some log files somewhere that somebody here may know how to access and hopefully interpretate.

Edit:
I’ve now registered that the network highlighted in the search result list is not always the one on top of the list – whatever decides the ranking order(?) and whatever what the highlighting indicates(?). Usually it is the telco that issued the SIM card first used in the phone (with Android) that is highlighted, but as mentioned it may also be “my new” network.

Should perhaps also inform that:
a) whichever network is on top and/or highlighted, clicking a found network will sometimes result in the waiting icon, sometimes not. Whether it is the network corresponding to the SIM, seems to have no influence.
b) sometimes the search for network(s) end up in the message “Found no networks”.
c) sometimes the search go on “for ever” – and that’s not necessarily those times where no network is found at all.
d) when I get said error message regarding connection problems, the Network field under “Select network automatically” may display “Connection denied” – or just “Searching” …
e) If “Select network automatically” is selected, the Network field below displays “Searching” - also if the search has ended with a list of found networks (i.e. it seems “Searching” is displayed as long as no connection is made.

You normally shouldn’t have to do anything at all beyond inserting the SIM.
Did you test it under Android on the same phone?
What’s the band and coverage situation like?

This won’t help, as you noticed.

These settings come into play only after having found the network, so that is reasonable.

So maybe the automatic connection “works” but runs in to this same problem.
Are you using some picky (US?) operator that applies arbitrary whitelists, or that demands VoLTE?

Probably allowed/preferred by SIM.

Is your new operator a MVNO of the former?
Have you tried using any of the older technologies (2G/3G)?

Yes, card worked under Android. It’s from one of the two major national (and international) providers, that I’ve used for many years – in addition to, as mentioned, used it on Xperia X with SF 4.1, I’ve recently used the same card on a really old Nokia. No demand for VoLTE … and coverage is quite OK

I’m not aware of where I can select 2G or 3G before I have any connection - is that in some kind of configuration file somwhere?

I don’t know what MVNO means, (I guess V is virtual), but the two operators are major competitors who run their own national networks

1 Like

Karry, the absolute hero, just published a 64-bit build of Ofono Logger on OpenRepos (pending the official one)… perhaps that can shed some light on things.

Thanks a lot for making me aware of this – I didn’t know Ofono from before.

I’ve tried with 2G and 3G, but regrettably that didn’t solve my problem either.