Hotspot broken for certain providers?

I have an odd problem. I have both a XA2 and a 10 III. I use dual sim for both. On both phones I have problems using the hotspot when using the (dutch) KPN network. I can use the hotspot with the other sim, which uses a prepaid Vodafone sim. (different sims for both phones, but both 2nd sims are on the Vodafone network) Internet on the phone when using the KPN network works.

I would like to know which setting(s) influence if the hotspot works or not. I suspect it might be related to the 4G calling option, but I’m not sure.

I would appreciate some hints or help resolving this issue, as it’s a major hindrance right now.

P.S. same KPN sim works fine when using an Android phone (FP2)

The prime suspect is the IP setting: IPv4/IPv6/both.
If you suspect some specific setting, like 4G calling, just try!

I tried connecting my laptop to the hotspot of my 10 III and opening a webpage with different settings both on the laptop and on the phone.

I didn’t get any internet connection with the data access point setting for KPN set to IPv4, not even on the phone itself.
I did get an internet connection on the phone with the data access point setting set to IPv6, but not with the laptop connected to the hotspot. The setting for 4G calling did not change this behaviour either.

I tried pinging a website from while connected to the hotspot. I did get an IP for the requested domain, but no pings came through.

Setting the IP to both had the same results.

I don’t think the IP setting is the problem.

Anything else I can do to further diagnose the problem?

I’d presume that is your problem right there.

??? I guess you misinterpreted what I reported here.

tl;dr: The IP was set to “Both” before the test. When using “IPv4” as the setting in data access point settings, no connection was present at all. When using either IPv6 or Both as the setting, the phone has internet but the hotspot will not serve internet traffic. The 4G calling setting does not influence the result.

No, i take that as IPv4 not working on that network. And internet sharing is IPv4-based.

1 Like

Doesn’t the phone do a bit of routing in order to facilitate this?

I don’t belive it does, no.

You might be right. I just checked the returned IP when pinging a domain using the terminal app on the phone.

I got an IPv6 address as the target while using the KPN sim and when doing the same for the Vodafone SIM, pinging the same site returned an IPv4 address.

Is there any way to fix this?

I have no idea what happens if you manually set a ipv6 nameserver on your laptop but it might be worth a try.