Hosts file ignored

REPRODUCIBILITY (100%, always):
BUILD ID = OS VERSION (4.0.1.48):
HARDWARE (Xperia X F5121):
UI LANGUAGE: Russian ( Hungarian, English )
REGRESSION: (compared to previous public release: Yes):

DESCRIPTION:

My life is mine. Not for google, facebook or others…

I use my own hosts file, which is ignored by the operating system.

I use the same hosts file on my desktop under Debian Linux. If I type in a 127.0.0.1 IP-disabled website on the desktop, I receive the error message, that the server is not available. It’s the right.
If I enter the same address in the phone browser, the web pages normally works. It’s not right.
Here’s a piece of the hosts file. You can see that both sites are banned.

PRECONDITIONS:

STEPS TO REPRODUCE:

EXPECTED RESULT:

Forbidden pages should not be loaded.

ACTUAL RESULT:

Banned pages are loaded.


ADDITIONAL INFORMATION:

2 Likes

I would say a duplicate of

Workaround is described there.
Or just install Defender II (which has this hack).

Or wait for Jolla to possibly fix this soon™ but up to now it seems no one has noticed so i would not expect it to be fixed in new release.
Or maybe be surprised :wink:

2 Likes

Hi!
I’m sorry, I was careless, and many thanks for your answer.
I used the browser knowing it would take into account my own security settings.
This is a serious security risk, that provides personal information without the user’s knowledge. I discovered it by accident, too.
Off.
If someone doesn’t want - can - live without google, go buy an android phone…
On.
Jolla says : security and privacy are important.
To fix the problem, unfortunately, I have to avoid using the browser.
:face_with_raised_eyebrow:

I installed the app and it works perfectly in the normal sessions of the browser. It does not apply to the private browsing sessions for some reason. I will check if I missed a setting.

This I never experienced. So…

But it also does not belong here but more in the defender thread then, or?

For me, host file works as expected with private browsing. I use hosty (https://github.com/astrolince/hosty) instead of Defender II

3 Likes

Please see  

1 Like

The question is : when… :face_with_raised_eyebrow: ( :slightly_smiling_face: )

What do you mean ‘when’?
This is fixed in 4.1.0. Reason I posted it here.

I tried OTA update my F5121. the device sad : “Up to date” ( 4.0.1.48)
If you like, I’ll send you a screenshot in Russian, so it says “The system is up to date.”
Off
I’ve never been able to update the system in the factory way!
On
Is the update available?

This update is only available for those who have signed up for Early Access (EA) in their Jolla account (not settings on the phone). General availability will come in a couple of weeks. And i think i read somewhere that OTA updates in general are only for those with paid licenses. Maybe either of those is your issue?

I also do not get the UI notification on my X with free license (test device only). And this one is on EA subscription.
Never got this. Neither from 3.3 to 3.4, nor from 3.4 to 4.0 and also not from 4.0 to 4.1.
And the update from 3.3 to 3.4 and also to 4.0 was not the EA but the PR.

orly?
Can someone confirm?

One can always go the manual way

devel-su  
ssu re x.x.x.x  
version --dup

or even better rely on @olf’s sfos-upgrade tool.
https://openrepos.net/content/olf/sfos-upgrade

Sorry for the OT, but:

2 Likes

I did not know/read this but fair enough!

Good to know to not waste time waiting for update notifications :slight_smile:

I read it, and it does say that. Then why is OTA in the free system? :confused:
And one more question.
Where can I find the list of available versions? That’s what I need know for sfos-upgrade script.
Many thanks for your help.

No, you don’t: sfos-upgrade does check, if a given version number is a valid (and hence available) one.
If you also want to do that manually: Take a closer look at sfos-upgrade ('s source code).

1 Like

Thanks for the advice.
Sfos-upgrade told me : NO UPDATES FOUND
Off
(This is not for this thrade : there are some problem with script : /usr/bin/sfos-upgrade: set: line2: illegal option -o posix).
On
Does that mean I have to wait until the new version is officially released?
The question remains : when?

  1. Thanks for the bug report.
    The “illegal option -o posix” is harmless and only occurs, if one does not have bash installed.
    sfos-upgrade 3.8.2 shall work on all SFOS releases (again, now including 4.x), with or without Bash installed.
  2. Yes.
  3. As always, in “Jolla time” (which may be soon, but usually is rather later :wink:).
1 Like