Higher number of app crashes in 4.4.0.58

Hi all, can’t really fill out the bug template with this, so thought I’d mention it here first.

In the latest version on an XA2 Ultra, I find that the browser, email client, the clock app (once or twice) and possibly the text message client (that has a long standing crash issues already but it might be more frequent) tend to crash a lot more frequently than before. It’s not that frequent - maybe a few times a week - but they very rarely crashed before. I don’t recall it happening to any other apps, but I don’t use that many that often (except Piepmatz), so that may just be my usage pattern.

There’s no real pattern, it’s mainly while opening a page or email, or scrolling in either of them, but I think I’ve seen the odd one on other events. The app crashes to the home screen, with the greyed out cover image, and reopens on reactivation and the event that caused the crash can be carried out, with no problem.

I do leave the browser, clock and email clients open a long time, so it may be to do with that. It’s definitely with this version though.

There’s no reliable way to reproduce it, so is there any non-resource intensive way to capture the crash events, by having something running in the background? Or some other debug method I can use?

Thanks.

1 Like

They are likely events of things killed through the OOM killer.

One of the side-effects of SailJail is that the venerable “booster” concept doesn’t work as well any more, and applications use more RAM than previously (or rather, share less) (source).

If these are indeed OOM events, you should be able to see them in dmesg or the journal.

Try something like

dmesg  | grep -C3 oom_reaper

And see if fit matches the time of the app crashes.

3 Likes

Yes…with less available memory, the probability is higher.
Regarding browser, I get this with dmesg:

1 Like

Thanks for the information. It would make sense, though it’s a bit irritating if it’s killing the application I’m actively using at the time, if so. I’ll wait for the next crash and run that command. I might also look to have fewer apps open at a time and see if it improves too.

I am also experiencing those random crashes on XA2 4.4.0.58 - notably browser, gallery, and email apps. I have managed to get the output from journalctl after a browser crash - it crashed during normal web browsing just after opening a new link. Nothing can be found on dmesg output as suggested above. Do you have a clue on further investigation?

maj 11 20:26:31 XperiaXA2 kernel: binder: 9071 RLIMIT_NICE not set
maj 11 20:26:31 XperiaXA2 autologind[5025]: *** signal=17 pid=33
maj 11 20:26:31 XperiaXA2 /usr/libexec/mapplauncherd/booster-browser[7085]: warning: Boosted process (pid=17478) exit(11)
maj 11 20:26:31 XperiaXA2 /usr/libexec/mapplauncherd/booster-browser[7085]: warning: Daemon: sending exit(11) to invoker(-1)
maj 11 20:26:31 XperiaXA2 invoker[8526]: warning: application (pid=-1) exit(11) signal(0)
maj 11 20:26:31 XperiaXA2 lipstick[5317]: [D] onDestruction:268 - coverActionIndicators destroyed sailfish-browser.desktop
maj 11 20:26:31 XperiaXA2 kernel: msm_vidc: info: Closed video instance: 0000000000000000
maj 11 20:26:42 XperiaXA2 fingerterm[23382]: [D] unknown:0 - Using Wayland-EGL
maj 11 20:26:43 XperiaXA2 art[13804]: [D] unknown:0 - Messaging :  opening database
maj 11 20:26:43 XperiaXA2 invoker[6576]: WARNING: An inactive plugin is misbehaving - tried to show a window!
maj 11 20:26:43 XperiaXA2 invoker[6576]: WARNING: requestActivate() called for  QQuickView(0x14d450)  which has Qt::WindowDoesNotAcceptFocus set.
1 Like

I am experiencing them as well - almost always it is the browser and messages apps that crash.

The browser seems to self recover - or at least the screen minimizes to the cover with a rotating circle in the middle. If you wait a bit you can maximise the cover and the web page you were viewing reloads.

With the messaging app the screen minimizes as above, but after a while of the rotating circle the cover just disappears. You then cannot restart the messaging app (you just get the cover, rotating circle, and then it disappears) no matter how many times you try. Only rebooting the phone enables you to restart the app.

This happens reasonably frequently and it doesn’t seem to make any difference if there are multiple apps open or if the browser or messages app is the only one open.

I’m on XA2 and 4.4.

I’ve had two crashes to the browser in the last day, and that command produces no output, so I’ve done a browse of the dmesg output for the rough time and not seen anything obvious (too me, anyway).

I don’t see that behaviour with the message app generally, though I did get it once or twice a long time ago (several versions and devices). Have you tried reinstalling it?

For me, the message app sometimes crashes on send, and can be opened immediately with the failed message marked as failed (and with the resend button available) and the same text from it in the message field, ready for editing and/or sending.

Well, the phone is a freshly flashed XA2 with 4.4.0.58, no patches, no patch manager and no other non-standard mods - so the messaging app shouldn’t really need to be installed as its pretty much vanilla SFOS, should it?

I guess not. Just thought it might be worth a try to get a working system.

It might be a separate issue though, so may be worth it’s own thread in Bugs?

I’m pretty sure its already been reported as a bug some while ago - pre 4.4, but it seems that 4.4 has made it worse. Whether its the same issue as affecting the browser or other apps, or even if its nothing to do with the apps per se but down to OS memory management, I don’t know though.

Ah fair enough. I guess we’ll need to get to the bottom of this one to know if it’s related.