Has anybody gotten app called SmartumPay to work?

Hello,
Anyone had luck with SmartumPay android app to install/function?
I’ve tried to download it via ApkPure, but it just says that “Download failed” and nothing more.
Other apps download just fine via ApkPure…
I have XA2 with 4.0.1.48

It’s been a while since this was posted, but I actually got the SmartumPay to install. It works just fine trough Aurora store (which downloads stuff directly from play store, and can it self be installed from fdroid).

The app also launches just fine after installing, but unfortunately the log-in process doesn’t seem to work. It does open the browser for authenticating, but the app immediately complains that the user cancelled the log in process. (It says that this might be due to opening the app before completing authentication in the browser…) Likewise the authentication page in the browser seems to freeze after logging in both using the account method as well as the Strong Identification options. :confused:

If anyone has had more luck with this, or has a work-a-round for the log-in, I’d be more than happy to hear!

Haven’t used SmartumPay, but just random thought that came to my mind: Have you tried downloading some browser for Android and opening the login page with that if it makes any difference with callbacks?

2 Likes

Oh wow, that actually worked. Thanks avhakola!
I just installed firefox and thats it. Didn’t even need to change the default browser. I didn’t try to actually pay yet, but it seems like it should work too.