Graphical glitch in Clock Countdown/Timer App/Widget

REPRODUCIBILITY (% or how often): 100%
BUILD ID = 4.3 and 4.4
HARDWARE (XA2, X10, X10 II, …): Sony X Compact (Patched Xperia X Fullversion)
REGRESSION: since/with 4.3


A Graphical glich (a filled area) showed up in the Homescreen-Widget between the Countdown-Timer and the Analog-Clock (see Screenshot)



  1. Start Clock and set/start a 30 Minute Countdown/Timer.

Not sure to understand correctly all described steps. Are they correct:

  1. Enable an alarm. Do I have to set a specific time?
  2. Set a 30 minute countdown
  3. Start the countdown
  4. Minimize clock app

On my X10 II running Sailfish 4.4, I see no glitch. Could someone with a Sony X Compact confirm it’s a specific problem to this phone?

Thats all to trigger this. Maybe this is Xperia X-Specific or just the Xperia X Compact Devices with the Patch from “g7”.

Yes, perhaps. Tried on XA2 Dual 4.4. Timer cover is working correctly.

It would be useful to know if anyone experiences this on an officially supported device (to help narrow down what the issue might be). The filled countdown timer outline is rendered using shaders, so it could be related to that.

ahoy flypig,

I just tried to reproduce the bug as described. Couldn’t see the glitch. I see the analog clock and under that two lines: the next Alarm and the count down Timer. All seem to work fine! I use Xperia 10 ii official sailfish, Build (Vanha Rauma)

Thanks for checking this @nas, much appreciated. This does reinforce @pherjung’s suspicion that it’s X Compact related.