GPS stopped working

GNSS receivers start in 3 possible modes:

  • Cold start: This is seldom used. It happens when the receiver has been off for extended periods of time (weeks) or powers up far away from its last known position (hundreds of km). In this case, it needs to rebuild its almanac (satellite constellation database).
  • Warm start: This is the most likely condition. The receiver powers up in proximity of its last known position, after more than about two hours from the last fix. This requires to rebuild ephemeris data but not the almanac. Fix time is about 30 seconds.
  • Hot start: The receiver powers up less than about two hours from the last known fix, and not far away from it. It takes some seconds to get a fix.

If the XA2 GNSS receiver takes 15 minutes or more to get a fix (it took 1 hour some days ago), then there is a problem. It might lie in the software, where someone destroys the almanac, which maybe did not turn up until now thanks to A-GPS assistance; or maybe someone destroys the almanac on purpose, thinking that A-GPS will step in anyway (which it does no more). It might also lie in the hardware, where no backup power is supplied to hold the data, but it’s a big design flaw and not likely to happen in a product such as a mobile phone from an established manufacturer.
Now I am trying to leave GPSInfo on (which will leave the GNSS receiver powered) until this afternoon. If I get a fix in a reasonable time, this means that something bad happens when the receiver is powered on.

7 Likes

GPS with my XA2 with SFOS is hopeless, but an unofficial SFOS on XZ3 works flawlessly, so the issue might be somewhere else with XA2

2 Likes

For me it’s not just the fix that is slow. The gps is unreliable, the fix is lost during use and there’s gaps in the recorded track.

@pmelas I have an XA2 and a Jolla C. Jolla C GPS seems to work a better. But my XA2 works fine with Android on it so the hardware can’t be all uselesss. And actually GPS with Sailfish works fine for about a week if I flash Android on it and then flash Sailfish back. Or that’s my experience at least as I’ve written earlier in this thread.

2 Likes

@pmelas
Have to concur that provided “Device-only mode” selected GPS fix quite rapid upon XZ2Compact “Sailfish port”, although wondered whether plastic back cover aids GPS antenna reception compared to metal back of XA2.

1 Like

Update: Leaving GPSInfo on all day resulted in a faster fix. This was tested only once, so YMMV until further tests. Shutting down all apps, the GPS position icon on the bar stayed active and there was no way to make it disappear, not even turning the GPS off and on again. This means that for sure there is something wrong somewhere. I rebooted the phone to turn the GPS off for real, and the time for a new fix was about half a minute.

2 Likes

Thanks for all replies & observations so far. We have an internal bug report about this problem and it is being worked on at the moment.

15 Likes

Awesome, thank you for the update!

Both my XA2 and XA2 Ultra are almost unable to get a GPS position - sometimes taking several hours - but I read the whole thread, and it’s great to see actions being taken!

Still, I have a few questions:

  • How can I perform a cold start on my XA2 device? I can’t remove the battery…
  • Is there some other service besides MLS that could be used?

I’ve been using the exclusive mode now and contrary to my previous experience gps does work better. Getting a fix is still slow but once location is found it’s accurate and there’s no gaps.

Now I start GPSInfo in advance when I’m going for jog or something and place the phone outside. Getting a fix takes five to ten minutes.

A question: With MicroG you can use a MLS location backend. What Android apps use this service? All apps or only ones using some Google service for location? Is this service used when using Android apps with SailfishOS?

To my regret GPS has stopped working again. It worked only once with the suggestion of Andrea (Mozilla off). Now no GPS at all. Navigation is impossible.Jolla, can you please fix this?

I could never use any navigation apps on SFOS until today. Based on some suggestions that I read here, I turned on location (high-accuracy positioning), fired up CSD tools, clicked on GPS satellite lock in the options, and left the device on the table in my yard a couple of minutes. After maybe 10-15 minutes (maybe less, I am not sure), it locked the position, I opened Pure maps, and finally, it worked. Thx for suggestions, good people.

3 Likes

Because I read so much here about not working GPS, I tried repeatedly, last time just now.

Now I made a very interesting observation I never made before:
Just now I tested with running mobile access point, that is WLAN on + mobile data on. Indeed the GPS did not sync! There were 20 or 25 satellites visible after a few minutes or less than a minute, but even after 10 min. no position fix.

Next I turned GPS off, then WLAN + mobile data off, then GPS on again.
Result: after 2 or 3 sec. till more than 20 satellites occur as visible, <30 sec to position fix and 5 satellites sync’d!

Maybe the transmitting signal from both the WLAN and/or the mobile data connection interferences the GPS receiver??

Receiving conditions: inside the house in rural environment.

2 Likes

I tried this last night. I haven’t managed to get GPS lock while inside unless right next to a window, if even then, but this method gave a GPS fix fast. However I tried this again today in same exact location but no luck even after waiting for several minutes. But I then decided to turn off my bluetooth headset and my laptop’s wireless connections (which were not on last night to begin with), and pretty quickly GPS fix was established, and GPSInfo app gave me 4/40 satellites. So now that I turned mobile data and Wifi hotspot on, it’s back to 0/40 satellites.

This method doesn’t work 100% but then again I have quite a few other wifi access points around me. Yesterday on walk I did get a GPS fix immediately when I was far away from all buildings. So…maybe there’s something in it.

edit: well, I had 0/40 satellites again when I decided to move on to other things for now and no wireless connections (other than the neighbours’). I turned on wifi hotspot and mobile data on from the phone, wifi and bluetooth from the laptop and the wireless headphones; immediately 5/39 satellites on GPSInfo app.

1 Like

Update 2: Leaving GPSInfo on at all times not always results in a faster fix. It looks like I get a faster fix if I had got a fix not too much time earlier (I can read the time of the last fix in GPSInfo). Maybe the warm start does not work for some reason, but the hot start does.

Observations: my J1 with no SIM, so GPS only, gest a faster (like 1-3 minutes) fix then XA2 (like 5-10 minutes) with all the aGPS and MLS.

1 Like

With 3.4.0.22 the GPS seems worse than ever before. I am living 700 metres from Copenhagen Airport which should be as heavily a GPS sensitive area as is possible and I can’t get a fix, standing on my balcony on the third floor! I have tried with different settings, but no difference. SIGH, this is really disappointing!

2 Likes

After the update to 3.4.0.22, GPSInfo reported no satellites. The phone booted up after the update with the GPS turned off, then I turned it on. After a while (about half an hour), I turned off the GPS via the GPSInfo menu. That did not work, the SailfishOS GPS setting stayed on. I turned that off and on again, then turned on again the setting in GPSInfo (which was appearing to have no effect whatsoever). At this point, I got 22 satellites (a low number anyway, but more than zero), and got a fix in some minutes. All of this strongly points to something wrong, possibly in the AOSP middleware.

1 Like

Hello, can you specify the device you are using?

1 Like

Hi, what device are you using?

I too face the same issue in my Xperia XA2.
Compass calibration: 100

GPSInfo is showing 0/0 satellites.