GPS stopped working

I had similar problems with the GPS.

I assume, that there are some incompatibilities or difficulties/bugs between the GPS receiver and the whole system around it on the one side and all the precision location services like Mozilla location service (Mobile Tower data) on the other side. Found also no way to solve this.

So I switched all this extension off using “settings/location service/”:
High accuracy - off
Battery save mode - off
Exclusive mode - on
Individual settings - off

This works on my phone.
This also works:

High accuracy - off
Battery save mode - off
Exclusive mode - off
Individual settings - on,
and then

GPS position fix - on
Mozilla + Mobile network - off
Mozilla + WLAN Hotspots - off

I can confirm that GPS with all other settings does not work, but if it’s done as described above, it should work. Please try and report, I am curious!

3 Likes

I’ve tried the Exclusive mode but it doesn’t seem to make a difference in my case.

2 Likes

For me on my device (XA2) it just does not matter what I have selected. With or without MLS it just takes as long as it takes to download almanach from satellites in view. Under good circumstances it is quite fast, if moved long distance from last position or bad weather or (leaf) roof above it takes longer. Even up to 12 minutes is then possible :frowning:

I do hope that MLS somehow gets (or better; get allowed) to continue the service!
Another question is what Jolla will do in next release 3.4? Will they remove MLS from options? And replace with???

Oh,
and an official statement from Jolla would be appreciated if they are allowed to continue using MLS and/or MLS should be still working on our devices. Or whatever?
Just some clarification, please!!!

4 Likes

Do you know for sure that Mozilla Location Services provide the almanac? My current, mainly guessed, understanding is that a-gps provides the almanac and MLS does not provide a-gps data.

Maybe getting the current approximate location from MLS helps with the position fix I don’t know. But at least according to this map MLS data in my area is so scarce that it wouldn’t do any difference.

But even if it was just down to MLS or just down to a-gps that would not explain why the location fix is lost during use. Location is know at that point.

Of course MLS options in the settings should be removed if they are not used in any way.

EDIT: Ok, I just tried browse for a-gps, again, and my understanding was that a-gps only means that the almanac can be downloaded from the internet. But apparently cell tower or wlan network positioning is also a form of a-gps and does help with getting a position fix quicker.

I am absolutely not sure. :wink:

But I did some research years ago (in German and still Symbian times :D. Maybe not 100% correct, but I think so):
http://www.faq4mobiles.de/thema/was-bedeutet-eigentlich-gps-agps-unterstuetzes-gps-netzbasiert.71257/

The cell tower triangulation, location of WiFis can provide a very-close estimation of your current position at real time (even provide posituin without real GPS). And the closer you are to the GPS position the less data needs to be downloaded from satellites for calculating correct position.

And:
I asked via Zendesk about the status of MLS in Sailfish…

2 Likes

You do not download data from satellites. The GPS receiver uses the time delay of signals received from satellites to triangulate his own position. The best is your initial approximation, the lowest the time required to calculate a fix.

2 Likes

I think the almanac is downloaded from the satellite. It can be downloaded from the network. I don’t know how long the almanac is valid. See https://en.wikipedia.org/wiki/GPS_signals#Almanac.

But apparently knowing your current rough position does speeds up the position fix and with current hardware almanac isn’t really needed.

1 Like

The almanac should only be rebuilt at cold start or reset (such as after a failure of battery backup), since without it it’s impossible even to start calculating a fix, so often only once (or very few times) in the whole life of a GPS receiver. If the issue lies with the almanac, there is a serious software error in the GPS driver.

3 Likes

+1

Almanac is crucial to get accurate fix. A-gps is just helper to speedup geting full almanac.The same for MLS as somebody mentioned before.

2 Likes

GNSS receivers start in 3 possible modes:

  • Cold start: This is seldom used. It happens when the receiver has been off for extended periods of time (weeks) or powers up far away from its last known position (hundreds of km). In this case, it needs to rebuild its almanac (satellite constellation database).
  • Warm start: This is the most likely condition. The receiver powers up in proximity of its last known position, after more than about two hours from the last fix. This requires to rebuild ephemeris data but not the almanac. Fix time is about 30 seconds.
  • Hot start: The receiver powers up less than about two hours from the last known fix, and not far away from it. It takes some seconds to get a fix.

If the XA2 GNSS receiver takes 15 minutes or more to get a fix (it took 1 hour some days ago), then there is a problem. It might lie in the software, where someone destroys the almanac, which maybe did not turn up until now thanks to A-GPS assistance; or maybe someone destroys the almanac on purpose, thinking that A-GPS will step in anyway (which it does no more). It might also lie in the hardware, where no backup power is supplied to hold the data, but it’s a big design flaw and not likely to happen in a product such as a mobile phone from an established manufacturer.
Now I am trying to leave GPSInfo on (which will leave the GNSS receiver powered) until this afternoon. If I get a fix in a reasonable time, this means that something bad happens when the receiver is powered on.

7 Likes

GPS with my XA2 with SFOS is hopeless, but an unofficial SFOS on XZ3 works flawlessly, so the issue might be somewhere else with XA2

2 Likes

For me it’s not just the fix that is slow. The gps is unreliable, the fix is lost during use and there’s gaps in the recorded track.

@pmelas I have an XA2 and a Jolla C. Jolla C GPS seems to work a better. But my XA2 works fine with Android on it so the hardware can’t be all uselesss. And actually GPS with Sailfish works fine for about a week if I flash Android on it and then flash Sailfish back. Or that’s my experience at least as I’ve written earlier in this thread.

2 Likes

@pmelas
Have to concur that provided “Device-only mode” selected GPS fix quite rapid upon XZ2Compact “Sailfish port”, although wondered whether plastic back cover aids GPS antenna reception compared to metal back of XA2.

1 Like

Update: Leaving GPSInfo on all day resulted in a faster fix. This was tested only once, so YMMV until further tests. Shutting down all apps, the GPS position icon on the bar stayed active and there was no way to make it disappear, not even turning the GPS off and on again. This means that for sure there is something wrong somewhere. I rebooted the phone to turn the GPS off for real, and the time for a new fix was about half a minute.

2 Likes

Thanks for all replies & observations so far. We have an internal bug report about this problem and it is being worked on at the moment.

15 Likes

Awesome, thank you for the update!

Both my XA2 and XA2 Ultra are almost unable to get a GPS position - sometimes taking several hours - but I read the whole thread, and it’s great to see actions being taken!

Still, I have a few questions:

  • How can I perform a cold start on my XA2 device? I can’t remove the battery…
  • Is there some other service besides MLS that could be used?

I’ve been using the exclusive mode now and contrary to my previous experience gps does work better. Getting a fix is still slow but once location is found it’s accurate and there’s no gaps.

Now I start GPSInfo in advance when I’m going for jog or something and place the phone outside. Getting a fix takes five to ten minutes.

A question: With MicroG you can use a MLS location backend. What Android apps use this service? All apps or only ones using some Google service for location? Is this service used when using Android apps with SailfishOS?

To my regret GPS has stopped working again. It worked only once with the suggestion of Andrea (Mozilla off). Now no GPS at all. Navigation is impossible.Jolla, can you please fix this?