GPS signal and backgound task

I use SailfishOS on an Xperia 10 III with version When I use a navigation app (Kuri, OSM Scout, Pure Maps) and it runs in the background with the screen off, the GPS is deactivated and is only available again when I switch the screen on.

This means that no route tracking is possible. Is there a way to keep GPS running in the background?

1 Like

I don’t recognize this problem. Did you try other positioning settings? I use high accuracy positioning all the time.

The high precision position mode uses also other additional services like A-GPS, cell towers and WLAN’s. This grants very much faster position fix after powering on theGPS module. To test only the ‘real’ GPS, better set to GPS only (Exclusiver Geräte-Modus). It seems that SFOS powers down the GPS receiver if the app using it is in background.
Q to the devs: Is it possible to tweak the system in a way, that the GPS receiver always runs if Location is on in the settings, independent if an app is running or it is in foreground or backgoound or even if no GPS related app ist running?

Not exactly answering to your question, However, I used to do tracking with Maep and it worked with screen off.
But I don’t know if it was in background (=another app in foreground before to switch off the screen) or not.


I’d like to put a big +1 here. Especially since with the XA2, the gps takes an awfully long time to get a position. I have a switch to put localization off or on. If it’s on, i expect my device to know every time where i am. If i don’t want that, i put it off.

I’d like the localization service to be always updating the current position if position is enabled, whether there’s an app using it or not.


Difficult to find it now/here as I have the phone only but @nephros posted a script/reference once, to updatee the GPS regularly. You will find it with the search engine.

If your XA2 takes more than 4-5 minutes to get a fix, it probably has a hardware issue that can perhaps be arranged.
Details here: [How-to][Hardware] Fix XA2 GNSS(GPS): Let's Try harder

No, it doesn’t use A-GPS, because the default settings in gps.conf don’t work.

Yeah, I tried device only mode and accuracy positioning. Also, I use SFOS on XZ2c. There it works in background. The positioning is recognized faster than my 10 III. So it’s possible that I have an issue with the 10 III.

Or it just need a reinstallation.