Google Play Store on Xperia XA2 and Sailfish 4

Hello,

is there a Chance to get Google Play Store to work.

Because i need one App for my diabetes management that wants to be installed original from the Google

Play Store.

Sony Xperia XA 2 with Sailfish OS 4.

If that needs Bluetooth, don’t bother. Pass-through of Bluetooth devices doesn’t work. (Audio works obviously, but not that the Android side will see it as Bluetooth)

The app works with NFC

I’m pretty sure the situation is the same there (but by all means do your own research).
Tried installing a generic NFC reader app, and it says there is no device available… and my Xperia 10 definitely has one.

Doesn’t sound like an exact match for your needs, but perhaps worth checking out: https://openrepos.net/content/pisarz1958/glukometr-diabetes-diary

Thank you very much.

I will have a look at it.

Are you sure the app isn’t available on the likes of APK Pure? Most apps Android app are there and there is an app Store for APK Pure.

Otherwise if you have access to an Android device download the app onto that device then using the Send Anywhere app transfer it to you Sailfish device.

You will copies of Send Anywhere on both devices. It is on the Android Store that comes with the Android support on Sailfish.

You will find some apps say they require Google Play Services to run. Very often they will run, but some functionality may be missing.

It worked on Xperia 10 for me… But not on Xperia XA2.

Install Aurora Store, it will let you access Google Play Store apps. The easiest way is probably to install F-Droid, if you haven’t yet, and then install Aurora Store from F-Droid.

@AlanBreen
I have downloaded it from APK Pure, but when i started the App there was the message that i should install it from the Original Google Play Store and it closed itself then.

@jameson
I have installed Aurora Store and F-Droid today. Then i installed MicroG Services, but
the Stores dont show me neither the LibreLink App nor the Google PlayStore App for installing.

When i log in the PlayStore by Firefox, then it shows only my Android Devices for installing.

It looks like it appears only for devices which report to be NFC-enabled. It is not installable on two of my Android devices.

That could be possible.
attah wrote that Pass-trough of Bluetooth and NFC doesnt work.
So i must look for some other solution.
Thank you all very much for spending time for my problem.

What part worked? And under what conditions? (i.e. what app etc)

NFC, but it’s now working on Xperia XA2

How did you test? Please give details!

Installed NFC Logger from OpenRepos, then ran it without NFC, then suspended NFC Logger. I turned NFC on, then proceeded to open the app and hold a known-NFC item near it, and it was able to send data (I’m not sure about retrieving data)…

Okay, yes that works just fine. But what the OP is after is to have it working with Android apps, which i believe is currently not feasible.

I’m not sure, but if it is seen in SailfishOS, you can use an NFC checker on AlienDalvik just to be sure…