Google Maps worked with Wifi but stopped when outside home ( 4g )

GPS worked in home and google navgiation was working i can find routes etc
and as soon as i moved out of house and the network switched from wifi to 4g ( i turned on the 4g ) it stopped working google navigation just stopped

I tested the internet working fine ( facebook vidoes ) and whats app messenger was working ,

But Google completely stopped so as Waze

the only software that worked was open maps

any ideas ? any help would be greatly appreciated.
I have stopped using it for now ( as its still cannot replace my daily driver due to GPS issue as i use it a lot as i use local buses to travel )

I managed to work with all the other apps

Out look
whats app
fB messenger,
calls ,
google drive ,
proton email
google photos
MS teams
LInked IN app

but the only software that didnt worked was Slack app it never worked

Sooo… people install SailfishOS only to then run everything through Android+Gapps?

FWIW, I’m not surprised that Google’s own apps, closed source, relying on gapps, don’t work reliably on SFOS.

Please don’t expect 100% compatibility.

Always look out for native SFOS alternatives.

I’m not sure about your “all the other apps” - are you saying you’re making calls & sms through the Android layer? And you actually installed the Gmail app instead of using SFOS mail client?

  1. Check your localisation settings in setting menu.

  2. When on wifi try to download maps (Through google maps app) ad then try to navigate without any internet connection. Doest it work that way?

  3. Turn off any internet connection. Do reboot. Connect to 4g first, then try it out? App support have known bug that couses loss of internet connection when switching from wifi to 4g

  4. Try Pure Maps, it wokrs well and it’s much more customizable than google apps.
    As in previous post. If you install SFOS only to work with android apps… that is not the idea here. There is a lost of alternatives out there. App support is intended to give you a way to still use your services of choice when there is no native app available

  5. Sailslack works just fine, under comments on open repos you can find a instruction how to make it work

1 Like

Thanks for responses i will try the sailslack again with the instructions mentioned
i can confirm after reboot the google maps started working again

so only thing is now sailslack so far thanks @Ride92 @ohnonot for pointing out .

only last query i tried moving whatsapp folder using scp command using ssh but it never worked

scp -r C:\my_folder defaultuser@1xx.1xx.x.xx:/home/user/
scp -r C:\my_folder defaultuser@1xx.1xx.x.xx:/android_stroage/android/media/com.whatsapp

any help would be hihgly appreciated because copying through MTP is taking around 45 minutes
i am very frequent user of adb as this is a fastest way to move data to and from android phone but i am quite new to linux ssh world so not sure if i can get the same speeds using SSH to move big files 1 GB plus sized folders etc.

i am quite fond of working with terminal or ssh if there is any easy way or any help on above would be great


In that case switching app support off/on should be sufficient.

How did it not work? Please try a better problem description.
scp should also provide diagnostig output, more if you add the -v switch.

SUre there are 3 attemtps

1st attempt ( c:\ )

cp C:\Users\nayya\Links\a.txt
cp: can't stat 'C:UsersnayyaLinksa.txt': No such file or director

2nd attempt ( double qoutes around c: address)

scp -r "C:\adb\pulled"
ssh: Could not resolve hostname c: Name or service not known Host key verification failed.

3rd attempt ( removed double qoutes and using forward slash / )

scp -r C:/adb/WA_VIVO
ssh: Could not resolve hostname c: Name or service not known Host key verification failed.

:grin: funny idea. I use native applicatios when they are good enough. Notes is quick to start and works well for shopping list so I use it. For navigation I require my native spoken language and currently only Waze works for me.

  1. you need to use scp
  2. are you on windows? The windows version of scp should™ know how to deal with windows-style paths. But I never used it so I wouldn’t know.

Try changing to the directory that contains the directory you want to copy, then issue

scp -v -r pulled

Notice the last slash at the end.

1 Like