Google apps in Xperia X?

Hi. Since Yalp Store went down some time ago, I’ve been unable to update my Gapps (basically, I just need Google Maps¹ and my bank app; but I’m afraid it’s going to be worse in the future). There’s a lot of info here about MicroG and Aurora, but it seems they only work on XA2 and 10. Is this true?

Since my Xperia X’s battery is getting old, I’m starting to wonder if I must go for a XA2 instead of buying a new battery.

¹ I know there are a lot of map apps out there, but I’m a professional driver and I need the traffic jams feature. There’s Waze, but I guess it also needs Google Play :frowning:

1 Like

I had waze running on my Jolla without GPlay…installed from Aptoide store.
There’s a nag screen stating it requires playstore but will run without.


Thanks, but that’s not my point. Waze is property of Google and they could “close” it as they’ve done with Maps (no longer available on Aptoide).

What I need to know: is there anybody here with a Xperia X (Myriad Alien Dalvik 4.x) who can download and install Gapps? Is it possible?

Anyway, long time since the last time I check Waze: it used to be not as good as Maps, but now it’s even worse for my needs. The UI is horrible to catch traffic jams at a quick glance.

Yes, possible … I have deodexed patched files to enable MicroG on X, but they no longer work on SFOS 3.x, since Aliendalvik has been updated from 1.0.85 to 1.0.90. I don’t know what the changes were, so it might be possible to tweak it to work, but it’s not hard to deodex and patch the current files - I just don’t have lots of time for stuff like that … I wondered about downgrading back to 1.0.85, but just downgrading the Aliendalvik package caused crash, so I guess I’d have to figure out what other packages need to downgrade also, (apkd or something…). Maybe I’ll make time soon…

1 Like

FYI, in case you want to test it, Here Maps has traffic jam info, too. I don’t know how reliable it is compared to Google / Waze’s one, though.



Since my Xperia X’s battery is getting old, I’m starting to wonder if I must go for a XA2 instead of buying a new battery.

G00gle are always closing loopholes as currently have F5122 now running upon which Gapps was installed wayback upon much earlier Sailfish OS using:
For now can still update apps via Google Play Store v7.3.25.K-all[0] and use Google Maps, however after resetting a F5321 recently it was impossible to replicate this behaviour and can’t download apps via Play Store anymore.
Please don’t purchase any XA2 at the moment as a replacement for your needs as currently GPS is too unreliable to carry out navigation, have a look at this thread:

1 Like

@fph Here Maps looks good, but requires “Android 5.0 or higher”. And when I load it into a mobile browser, there’s no traffic option (?!). I can request the desktop version using Android Firefox, but then it’s waaaay slow.

@aspergerguy Yeah, I know the trick, walked that path some time ago. Now I’m using a rather old Maps version; don’t want to mess with it and take the risk of screw everything up. Especially, after reading you about your F5321 issues.

About the XA2 or even a 10, I can hold on for some time. Anyway, those problems seem to be common to all Sailfish X devices and I have no complains about my Xperia X fixes/locks. Sure it’s a bit slower than Android, but nothing really bad.

Thanks everybody.

I am currently using it on an Xperia X (running Sailfish X ofc). Maybe I am just using an older version; mine is 2.0.12823, works just fine and get updates and traffic.

1 Like

Can confirm using Here Maps v2.0.12823 and Google Maps v10.15.3

1 Like

Hello! @mced… Well, after re-flashing my xperiaX using, lost play store. I was stucked with Aptoide (from Jolla store). But I needed G.Services running as many apps ask for it to run. I’ve tried a lot, and then I got it.
I used Google-installer 3.0 (found in google: After that, you have to sign in. If you do it the common way you get authorization failed. But if you click on the three dots (upper right corner) and select ‘browser sign-in’… You’re in!. Then I’ve test several versions of play store and 7.3.25 (search on google) is working ok. 22.4.x also worked. But 23.x.x didn’t. Google Play Services is 20.45.16, but i updated later.
Anyway, I think many versions work but the way of registering is the key to success.
Hope this helps!

ps: Google maps is working!

I am sorry but I am using navigation on my XA2, 3.4, with Here on a daily basis and it works just fine. I am using GPS only, so it takes a few hundred meters to get a fix. If I happen to have GPS off, which I always have when not navigating, it takes longer to locate when I am at a location far away from the point where the last GPS contact was. Flying e.g. from Vienna to Berlin and starting navigation in Berlin will cost you a minute or two.
But a XA2 is completely capable of decent navigation. Had the X before. That was faster, ok.

Does this work with xperia 10?

Have you tried Magic Earth :

It doesn’t require google play services and works from Android 4.1. It’s the default maps app on /e/ rom. And on my SFOS devices (Android 8.1 compatibility), it works great and smoother than here maps.

I mean will android apps really work, especially banking apps. I’m stuck in, unable to install 3.4. Banking apps need google play.

Some bank apps work with microg. Many don’t or with limited functionalities.
Even Android rom without google play services suffer the same issue (/e/ rom for example, they even ask users to E-mail banks about the issue).

1 Like

If one uses all the g apps and mainly android apps, why not run android on the device? I really don’t get it.

“all” & “mainly”? I use Sailfish because I like it. I use android apps that I need.


Yes! Bank apps are working in my case, at least the two or three I often use. Google services are running as some apps need them.
Currently running Sailfish
Try installing as I said above. Works like a charm!.

Well, I’m a coward: I’ve taken the XA2 path. It isn’t just the battery, but also my Xperia X’s microUSB port is starting to give me trouble. Sure both could be fixed, but I was not entirely willing to give any more money on a “only 4.4 Android apps compatible” device.

I’ve bought an “almost new” XA2 (€160) and I’m stuck in the “Important: use your Xperia XA2 some time with Android OS” step.

@jem555 Thanks for the interesting tip, but I prefer not to install any random APK if I’ve got any other alternative.

@apozaf The difference between using Sailfish with two “I really need them” Gapps (my case) and using official Android is the same as commiting suicide by shooting yourself or setting yourself on fire. Both mean death, but I really prefer the gun. A bit less painful.

An example (BIG offtopic, you don’t have to read it): got this Android Nokia phone for work. Last spring, they upgraded it to Android 10 and so I did; but the upgrade was faulty and carried this annoying bug: no notifications for any app while it wasn’t running on foreground. Take WhatsApp. I need it because my boss and our customers use it. And everytime OOM killer closed it, no notifications about new messages or chats. So I was forced to check it every 30 minutes and manually run it if it was closed. For six months, there was no fix from Nokia (actually, the company that bought the name “Nokia”, not related to our good old Finish friends who created and then trashed Maemo/Meego).

If this was Sailfish? Since we’ve got “easy” superuser privileges (rooting an Android device is complex and it has some disadvantages), I would have tweaked the OOM daemon/service and made an exception with WhatsApp: keep it running at any cost. Or I would have downgraded it to a previous version, bugs free.

That’s power. And I like it. My Sailfish phone is mine, not Google’s or Apple’s.

1 Like