Godot Texture Rendering on Xperia 10ii & 10iii

This is a fairly arcane topic, but I’m trying to gather as much info as I can. On the 10ii and 10iii I noticed while developing that the rate of animation for texture maps was irregular leading to choppy animations. On top of it, after some minutes of game play in Molecules, the rendering dropped to really low resolutions. This did not happen on Volla, GS290 or GS5. Only happens in the 3d (GLES2) context.

Proper resolution, beginning of game.

After a couple of minutes/levels:

Any one, @sashikknox , @mal, have an idea if I can compensate with render settings in Godot?

little bit miss understand what is wrong, both screenshots are same, as i see…
and Godot render pipeline not modifying by me, i just add some fixes for render rotation in Godot shaders ( some UV manipulations ).
But if your game run in portrait mode, my code not touch your game render.

You need to open the images and then click to zoom. You’ll see the difference. It has nothing to do with godot, per se. It has to do with texture rendering on the Xperia phones which, I believe, have less vram available than, for instance the Volla22. Look at the big green blob zoomed in.

The game in this case runs in landscape mode (it’s built with the 3.2 version since I can’t run 3.5 on phones other than the xperia).

@mal I just uploaded a 3.5 Godot version to harbour for others to use. It displays the above behaviour after a couple of levels. I think it might be something I can counter with the correct settings as it seems to be related to texture mapping memory limits? As i mentioned above, on the Volla and Volla22 the textrue map is always smooth.

I’m not sure, but with the newest version of this seems to be solved. Playing 10 levels and no artifacts.

1 Like