Glibc 2.34, glibc2.32 request

Hi everyone!

Im building small software and it SFOS said it need when starting
/lib64/ version GLIBC_2.34' not found /lib64/ version GLIBC_2.32’ not found

could anyone help me to find the quickest way to install these Glibc. seem not very common.

much thank you

You generally can’t/shouldn’t just install that. It tends to be very tied to what compiler version you have.
And currently we are a bit behind - but with work ongoing - see newsletters.

But that begs the question; how on earth did you manage to build against the wrong version?
Or is this a build error?

1 Like

hi !
thank you for quick reply.

I am building vpn rpm package from code, the installation on arm pi working fine but not on Xperia 10iii. architecutre same but Xperia sailfish require glib 2.34 & 2.32 for the application.

could you help me to find any work around.

ivpn build package rpm

thank you

Which build environment are you using?

SFOS SDK? Docker? Native? Something else?

There’s no point in trying to upgrade libc (provided in SFOS by glibc package) without upgrading the entire system. If you have glibc version 2.30 installed then the latest symbols are going to be labeled GLIBC_2.30. Which API are you trying to use?

Looking at libc 2.34 exports, it seems that most (if not all) exports labeled GLIBC_2.32 and GLIBC_2.34 are those previously exported by libpthread. It could be that you just need to re-link your app against libpthread to make it compatible with libc 2.30


On any GNU/Linux system, (g)libc incompatibility means you can forget it. If you can’t change the app to be happy with 2.32.