General email accounts not working after 3.4 update

REPRODUCIBILITY (% or how often): always
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


After upgrading to both of my general email accounts refused to synchronize. When I try to recreate the account creation tool says the settings are incorrect - but they are definitely not.
On the other hand exchange and google seem to work.


Unfortunately be tries on getting information from logs did not reveal anything. Any help for that is appreciated.

Edit: I just tested on a Jolla C only used for development and it worked. So the problem seems to have some unknown preconditions. Also I don’t get notifications for the working accounts anymore. Maybe it’s related…

What is your email provider? If it is yahoo, on their side, they recently removed the possibility to log in with less secure devices, which was needed by the sailfish client. That might be the culprit…

1 Like

I don’t think the culprit is the email provider, because

  1. There are two accounts not working (one self hosted and the other from
  2. It worked exactly until I installed the Sailfish OS upgrade
  3. It works on the Jolla C with the same upgrade installed
1 Like

After the patch to everything is back working. So the report can be closed.

1 Like