Found an old Jolla Phone and tried updating


I recently found my old Jolla Phone again. I read that sailfish support for that device expired, but maybe there’s still something i can do with it.

What i’ve done so far: I enabled developer mode to get ssh access, installed sudo with pkcon to be able to first ‘sudo su’, set a password and then ‘su’, took nemo out of sudoers again via drop in file in sudoers.d. After realizing that the jolla store has some troubles i started updating. 2 Updates worked, but after the last update some issues appeared. It basically works like before but i can’t see the basic app icons on main screen as well as a few icons on the applications screen (the apps still work when i tap on the place where the icons used to be).

According to the ssh-greeting-line ‘SailfishOS (Yliaavanlampi) (armv7hl)’ is currently running.

The last few lines from /var/log/zypp/history are:

# 2023-05-26 22:36:07 elfutils-libelf-0.156-1.3.4.armv7hl.rpm install failed
# rpm output:
# rpm: /lib/ version `GLIBC_2.17' not found (required by /lib/

I can’t tell what exactly went wrong during the most recent update but i was hoping that a retry via command line would solve the problem. I opened the terminal app, and ran ‘devel-su’ and ‘version --dup’. The App seems to be stuck with ‘REFRESHING CACHE’ for the last 30 minutes. What damage could interrupting the process most likely cause in this state?

Does anybody have a hint on how to catch up with sailfish updates if possible?


Since you’re on 1.1.2 reflash to factory settings (1.0.5?) and just spend the next 12h updating to 3.x, best to not tweak anything beforehand, developer mode not needed, just patience (that worked on my jollaC when it finally bricked at 4.4ish, so maybe only 8h will be needed)

1 Like

Thanks. Crtl-c did no further damage to the device. I’ll try a factory reset and proceed with your suggestions.

Perform a factory reset and use sfos-upgrade to upgrade SailfishOS (e.g. by downloading the recent version of sfos-upgrade, open a terminal, cd Downloads and installing it by pkcon install-local sfos-upgrade-<XYZ> (just hit the Tab key for filename-completion)), which will take care of some peculiarities when upgrading, e.g. disabling all OpenRepos repositories for certain upgrade steps (forgot which ones; if you are interested look inside the sfos-upgrade shell-script).