Flashing Xperia 10III fails - What to do?

So, I found an Xperia 10 III on Amazon at a good price - the right model and carrier unlocked. I checked that it had Android 11 and followed the Jolla instructions to the letter to install a newly purchased Sailfish X for the device.

I downloaded and extracted the ASOP binaries, the Sailfish image for the Xperia 10 III, etc and cd’d to the folder where they all were (I’m on Linux).

Unlocking the bootloader was successful and confirmed by the unlocked padlock display and ‘Please lock the bootloader - your software can’t be checked for corruption’ as it booted up into Android.

I shut it down again as per the instructions, connected the USB cable, waited for the blue light and did ./flash.sh

The flashing failed with 'Failed (remote: Erase of userdata is not allowed in a snapshotted state), the output being:

Flash utility v1.2
Detected Linux
Searching device to flash…
Found XQ-BT52, serial:HQ622R1088, baseband:62.0.A.3.163, bootloader:1322-1665_X_Boot_SM6350_LA2.0_R_52
Found matching device with serial HQ622R1088
Fastboot command: fastboot -s HQ622R1088

fastboot -s HQ622R1088 getvar secure
<< secure: no

fastboot -s HQ622R1088 flash boot_a hybris-boot.img
target reported max download size of 805306368 bytes
sending ‘boot_a’ (25800 KB)…
OKAY [ 0.805s]
writing ‘boot_a’…
OKAY [ 0.106s]
finished. total time: 0.911s

fastboot -s HQ622R1088 flash boot_b hybris-boot.img
target reported max download size of 805306368 bytes
sending ‘boot_b’ (25800 KB)…
OKAY [ 0.669s]
writing ‘boot_b’…
OKAY [ 0.100s]
finished. total time: 0.769s

fastboot -s HQ622R1088 flash dtbo_a dtbo.img
target reported max download size of 805306368 bytes
sending ‘dtbo_a’ (238 KB)…
OKAY [ 0.014s]
writing ‘dtbo_a’…
OKAY [ 0.004s]
finished. total time: 0.017s

fastboot -s HQ622R1088 flash dtbo_b dtbo.img
target reported max download size of 805306368 bytes
sending ‘dtbo_b’ (238 KB)…
OKAY [ 0.015s]
writing ‘dtbo_b’…
OKAY [ 0.004s]
finished. total time: 0.019s

fastboot -s HQ622R1088 flash userdata sailfish.img001
target reported max download size of 805306368 bytes
erasing ‘userdata’…
FAILED (remote: Erase of userdata is not allowed in snapshotted state)
finished. total time: 0.002s
Flashing failed (1)

Obviously the phone won’t boot up into Android anymore coz its not there, and Sailfish is not there - so all it does is cycle in a bootloop.

What can I do to fix this?

Ok, so the bootlooping has now stopped and all I get is a warning triangle with a message ‘Your device is corrupt and cannot be trusted - it will not boot and will be powered off’.

I think I have a brick now.

I don’t think you’ve bricked your device. Maybe you could try: ‘fastboot snapshot-update cancel’ and start all over again?

Ok, consulting a Linux Phone guru friend of mine, we think we have made progress.

He’ not sure why the userdata partition was in a snapshotted state, but cancelling this should allow fastboot to overwrite it.

The command is ./fastboot snapshot-update cancel

but this won’t work because the Jolla supplied version of Fastboot in the Sailfish zip file for the Xperia 10III is too old and does not support this command.

The solution is to download the latest version of the SDK platform tools for Android at SDK Platform Tools release notes  |  Android Developers, unzip it and use the later version of fastboot from there.

I’m now in the middle of flashing, having passed the original error by, so we’ll see how it goes!

1 Like

Great minds (yours and my friend’s - not mine!) think alike - Thx.

I think at least Ubuntu repositories could have fresh enough fastboot? Worth a try maybe.

Edit: Of couse i cannot know what distro you are using, but the point is that maybe your’s could have fresh enough fastboot? And thanks btw. :slight_smile:

Ok, so the flash was successful - Phew, was worried there for a while!

Now the testing begins to see how much better … or worse … it is than my trusty Sailfish XA2’s …

1 Like

I’m glad it works. It is always stressful when something like that happens.

I was happy to go from XA2 to 10 III. Everything works so much better.

1 Like

Elementary OS - very MAC like and basically a completely new UI, etc on top of Ubuntu LTS 20.04.

Okay, maybe the SDK was the way to go. Fastboot man page from Ubuntu 18.04 or 20.04 doesn’t mention ‘snapshot-update’. So i cannot confirm it would work any better. (If anyone would have this problem.)

I feel the same way, @Blumenkraft :slight_smile:
Glad it worked out, @Steve_Everett !

I had a XA2 like that, but I managed to recovered it to Android with Emma on Windows. I then tried again to flash SFOS - this time succesfully.

I ran into the same issue during flashing my Xperia 10iii. Did download the newest platform tools and copied the new fastboot program to the previously extracted sailfish folder as mentioned here. Using the ‘snapshot-update cancel’ parameters first, ‘opened’ up the orportunity to have another go with flashing, I understood.
However, using the newer fastboot program required to change the md5 checksums accordingly, which the windows batch I used was checking. Fortunately the checksums are provided in the output. You can directly edit the file md5.lst. I think this is worth mentioning, when running into that kind of issue.

1 Like

If you do get to it to flash, and disconnect the cable to find it still has just the blue light and won’t power on, reconnect and issue “fastboot reboot” :slight_smile:

1 Like

I just got device. Bought licence. Unlocked bootlader and trying to flash. Anytime it erros with:

E:\Sailfish_OS-Jolla-\Sailfish_OS-Jolla->fastboot.exe -s HQ622R03F7 flash userdata sailfish.img001
< waiting for HQ622R03F7 >
Sending sparse ‘userdata’ 1/3 (767654 KB) OKAY [ 18.776s]
Writing ‘userdata’ FAILED (Status read failed (Too many links))
fastboot: error: Command failed
ERROR: Failed to execute ‘fastboot.exe -s HQ622R03F7 flash userdata sailfish.img001’.

Anyone can help? I tried various adb drivers as well as flashing device to adroid again with emma.
Please, I paid for the phone and for the licence and right now I spent my money for nothing

@Ride92 Do you have the correct device? Is it running Android 11? Do you have Windows 10 (not 11)?

Where did you get the fastboot command?

Sorry for not replying right away I was too busy playing with device as I was able to flash it in the end.
So, device was correct Im sure :smiley:
Windows 10 with many different drivers installed :slight_smile:

The problem Was, as it turns out?
I don’t know what it was. I changed the USB port and flash it without problems

1 Like