Flashing 10III fails

When flashing my 10III I get the following error:
Failed to execute ‘fastboot.exe -s HQ61AM0923 flash userdata sailfish.img001’

How to solve?

Change your USB cable/USB Port. Check first if fastboot recognize your device with:

fastboot devices

I have now tried with a new cable and USB port, same result.

I then tried on my Linux-Mint computer and here I also gets an error, a bit more informative:

elkiaer@oem-Qosmio-X300:~/Hentet/Sailfish_OS-Jolla-$ sudo bash ./flash.sh
[sudo] adgangskode for elkiaer:
Flash utility v1.2
Detected Linux
Searching device to flash…
Found XQ-BT52, serial:HQ61AM0923, baseband:62.0.A.9.11, bootloader:1322-1665_X_Boot_SM6350_LA2.0_R_54
Found matching device with serial HQ61AM0923
Fastboot command: fastboot -s HQ61AM0923

fastboot -s HQ61AM0923 getvar secure
<< secure: no
The supported Sony Vendor partition image wasn’t found in the current directory.
Please download it from
Ensure you download the supported version of the image found under:
“Software binaries for AOSP Android 11.0 - Kernel 4.19 - Lena”
and unzip it into this directory.
Note: information on which versions are supported is written in our Sailfish X
installation instructions online https://jolla.com/sailfishxinstall

Here after I did download the Software binaries file again but same error :frowning:

So what can be wrong?

Sudo bash starts probably in the wrong directory? Try going into ‘sudo bash’ first, then navigate to the directory and run the ./flash.sh there directly (without sudo)

Or just ‘chmod +x flash.sh’ and do ‘sudo ./flash.sh’

No luck on the your first suggestion:

Where is the binary? Is it sailfish.img001?

Neither the second suggestion.

Yeah you should extract the SW_binaries_for…lena.img (around 300mb) file in the same foldee

You skipped step 5.1, download the zip from Software binaries for AOSP Android 11.0 – Kernel 4.19 – Lena (latest) - Sony Developer World and extract it in that same directory and forget my suggestions

1 Like

Strange, cant see it in the Terminal window but its there in the browser window.

I will look into that after I have played some Badminton.

Because you’re not in the same directory. Start the terminal from your file manager or look for the full path of the binary.

Yes, I did that mistake to copy the file into the zip-file.
OK - that did help but a new error occur.
FAILED (remote: Flashing of userdata is not allowed in snapshotted state)
What is snapshotted state?

Solved :slight_smile:

I was not able to start the phone neither in SFOS or Android mode.
I therefore flash the Andoid to the phone using Emma.
I went through the installation guide one more time and now it works.

So the issue were me, I must have forgot something the first time.


I had also Problems on my First Flash to get the right KeyCombination pressed at right time.

1 Like