Fahrplan 2.0.32-2

I had missed Fahrplan, for train schedules, when I switched to daily use of SFOS 3.4 on a Volla phone (last week).

So, remedied by, simply, compiling with the 3.4 SDK. I forked the original repo but made no changes.

As it stands only the bahn.de (Germany) backend was enabled with a simple compile. Works fine on the Vollaphone with 3.4.

I’m going to ping the original devs via github again, but thought I’d ask if I should take on maintenance in case nothing happens on that end.

What do you think?

The one thing

4 Likes

2.0.31 from the store works just fine on SFOS 4 on my Xperia 10.
(and that release is from 2017)

3 Likes

Segfaults on my Volla and if you look at the comments on the openrepos page you’ll see I’m not the only one. Also, the calendar functionality and some backends no longer work.

Smurfy is on it.

Also, My recompile ‘just works’ ™. I’d be interested to know why it would work on 4 but not 3.4 but that might be the case.

Same here - just fired it up again under Sailfish 3.4 (Xperia X) and Fahrplan 2.0.31 just works - in any case for bahn.de and ov9292.nl. Only the calendar function does not work.

on my XA2, Fahrplan ‘just works’ but not the calendar function. However I’d need a sbb.ch backend as I live in Switzerland, and without the calendaring function it’s much less fun as I prefer to see my travel info in the calendar. I’d very much appreciate to see fahrplan in full functionality again.

Hmm. Maybe it’s the kernel? In any case, I tried installs from the Jolla store and openrepos.

You all using openrepos or jolla?

Smurf mentioned there are differences. In any case I’m talking at him on:

Openrepos in my case (I think the calendarfunction is only present in that version, IIRC).

Yes, that’s the case. Can you chose a backend?

Yes, I can work with both bahn.de and ov9292.nl. Haven’t tried any others.

Another datapoint: I just installed Fahrplan 2.0.31 on my second Xperia X, which is at 4.0 - and there, Fahrplan does indeed crash on start.