F-Droid doesn't update some apps - on Android 4.4

I apologize in advance because I’m almost sure I’ve seen this covered in another thread before, but I can’t find it any more:

Starting with 4.2., F-Droid started to act up when updating installed apps. Some can be updated without any problem. Others (like Ankidroid and F-Droid itself) show up in the update-panel and seem to download correctly. When I try to actually update them, though, there’s just a generic error on the top of the screen and that’s it.

I have not so far tried to uninstall the affected apps, neither have I tried to uninstall and re-install F-Droid (which, well, is an affected app). That’s mainly because I don’t know how this uninstall/reinstall would affect the app data on the device, but also because (as I said earlier) I thought I had seen this problem here before and I’d rather do “the right thing” solving it than start experimenting on my own.

Any ideas? Like, for a start, can I see anywhere why exactly an update fo within F-Droid failed?

If previous version of .apk was signed with different key, then old package needs to be uninstalled first. I think it’s same issue on Android.


Should it is Xperia X this behaviour is due to the outdated and obsolete Android version.

1 Like

@kan_ibal and @vesa.s you both helped me, thank you. i first did what vesa.s suggested and uninstalled ankidroid, thinking i could re-install it. then i found out that f-droid claimed there was “no compatible version” for my device. now that was a strong hint and it’s kind of ‘compatible’ with what you said, kan_ibal: my device indeed is the Xperia X.
now i now the reason why, i dont have ankidroid on my device any more and I’m wondering if it’s worth buying a new phone only for the sake of android compatibility. oh my … decisions
anyway, thanks for the good input guys!

1 Like

You can download an older version of your app in Fdroid that might still support Android 4.

If that helps you deciding: the current Android app support of SFOS is very well implemented, really. Compared to the Android 4.4 based Alien Dalvik, it has improved by leaps and bounds. Kudos to Jolla for that!

In F-Droid, enable the repository “F-Droid Archive” and you can install older versions of applications that will run on an Xperia X. Essentially, the app has to require API level 19 or less (Android 4.4.2).

I wasnt even aware of the differences in Android support between the models. I must have missed that topic completely. Thank you for pointing it out.

And guess what? I have a fully working version of Ankidroid again. Happy! :slight_smile:

1 Like