Experience so far with using SFOS on an Xperia 10

After years of coming across SFOS and its predecessors like Meego online, I finally decided to get a device to play with, with the objective of having a secondary phone with no “Big Tech” (Google, Facebook, Amazon, Apple, Microsoft) whatsoever on it. Thus, I bought a cheap Xperia 10 to see what the experience is like. As a side-note, I am a fan of self-hosting, which should also help with this endeavor.

  • Onboarding worked fine, although it was funny how many steps backwards I had to take (script needed Android 9, which needed an unlocked bootloader, which needed the code from Sony, etc.) before I could start with Step 1 :smiley: Still, it all went smoothly all the way until I had a working version of SFOS on the phone, so kudos to everyone involved!

  • One special mention should be made to Sony and their 21:9 screens, which have made this particular phone a really fun experience, much more so than what I have been using for years (Samsung/Pixel/iPhone, all competent but completely boring)…it feels like the Nexus line is alive in these phones, given their pricing and hardware quirks, although I would really appreciate the presence of OIS and/or wireless charging in order to consider this series as a daily driver.

  • I was very interested in the SFOS Nextcloud integration, since I am running a Nextcloud instance at home and…it works quite well, except for one weird thing: the contacts were downloaded when initially syncing, if I edit contacts on SFOS the changes sync with Nextcloud, BUT if I add a contact in Nextcloud, it simply doesn’t show up on SFOS. Why it worked for the initial sync and then stopped and why I still seem to have at least one-way sync is something I just don’t understand. Backup in Nextcloud is fine, photo sync is fine, so it beats me why this is occurring with the contacts.

  • The Gallery app doesn’t display thumbnails of the pics stored in Nextcloud unless I first click on the picture. Maybe it has something to do with having a large camera roll folder, I will try with folders with smaller quantities of images, but still, quite weird, I would have expected bit by bit loading…nevertheless, it’s an app which works quite well for its intended purpose.

  • The overall UX feels extremely polished, which is a huge plus in using this phone…I like how the team took chances and made things work differently than on the other two platforms and the overall design and menu system feels superb. Much like with using Home Assistant, I feel like having a well-done UI has added tons of reasons to use this platform.

  • Having support for Android banking apps is also an excellent addition, which definitely brings it closer to daily-driver territory (depending on one’s needs, of course)

  • Android app support in general is well-implemented from my point of view…I stuck to the recommended path at onboarding and only installed Aptoide & F-Droid and have not added any of the independently-developed Google service replacements, alternative app stores, etc. Having switched from Android to iOS this year, carrying this phone daily alongside my iPhone has also had the benefit of letting me use some great Android apps which have no iOS equivalent (like nzb360), but it has also led to a major downside: no WireGuard VPN support. I have both WireGuard & Tailscale running on my Home Assistant server (haven’t decommed WireGuard yet because it does offer some advantages compared to going Tailscale-only) and SFOS can’t connect to them in a straightforward way. I will probably get OpenVPN up and running on my Nextcloud server, but that just adds a whole annoying level of complexity for only one device. There is definitely overlap between self-hosters and fans of mobile Linux, so getting WireGuard to work at OS level would be fantastic.

  • I mentioned the 21:9 screen previously and one thing it has allowed me to enjoy is 21:9 movies from my Plex server (using the Plex Android app), which are great on this phone!

  • 3.5mm or USB-C earphones work fine, but with Bluetooth devices things can be flaky. I tried the Samsung Galaxy Buds (which have a very low volume level and terrible sound quality, as mentioned elsewhere on the forum) & the Sony WH-CH510 headphones, which appear supported on the forum (and work fine for audio content), but introduce audio delay to the Plex video content, so are also a no-go for me. Not sure if the audio delay is due to the Xperia 10 being a slower device or not, but would love some feedback on this topic.

  • GPS is another sticking point - the old version of Android HERE Maps on the Jolla Store is the only software I’ve found so far which sees me in the general vicinity of where I really am (still 2 streets away, though) and all else I’ve tried (Pure Maps, the newer HERE Maps, etc.) fail to figure out the location, irrespective of whether it’s set to Precise, GPS-only, etc. OSM would be the logical choice for such a device, if the development team could somehow integrate its API as a preloaded app with proper access to the phone’s GPS.

All in all, it’s been a very fun experience and I really think more people should learn about SFOS, because the mobile Linux alternatives feel nowhere close to usable and the Big Tech alternatives are just one minimum-wage employee in a cubicle away from pulling the plug on one’s account (as seen by the recent Google “child porn” scandals).

For Android apps (which do currently form the bulk of my SFOS experience) I know I could probably run something like GrapheneOS, but AOSP Android is a usability turd, whereas SFOS genuinely offers a different perspective on using a phone…I haven’t been this excited about a project since discovering Home Assistant a few years ago and it really feels like there are a lot of people that could consider this “enough phone” (but probably only if the GPS issues are somehow resolved).

Great job, everyone!


@johnflorin Regarding the GPS issue, did you test OSM Scout and Pure Maps from Chum?

1 Like

Thanks for the suggestion! Nope, have not installed Chum, but will give it a go, I noticed that some devs have newer/better versions of their apps on Chum/OpenRepos/Storeman, right?

1 Like

Yes, that is. Please take care of file browser, if the version from Jolla shop still doesn’t show all folders in your home directory, the later version from OpenRepos/Storeman does.

1 Like

As it turns out, the GPS issue was due to me trying while inside the apartment, I read now around the forum that this doesn’t really work in SFOS…when I tried it at the window and checked that GPSInfo showed locked-in satellites, the mapping apps started working properly :slight_smile:

In terms of OSM Scout & Pure Maps, though, I didn’t like the way Pure Maps did public transport routing (very convoluted flow) and OSM Scout I guess also needs the server in order to search, so at the moment my “weapon of choice” is Android’s OSMAnd+, but I’ll go out and take it for a spin to see how well it updates while walking around.

Also notable is that Bolt & Uber don’t work, the former doesn’t show the map, while the latter complains about the lack of Google services. I see that both use Google Maps on iOS, so I guess it’s to be expected.

After installing Storeman, I also tried microTube, which weirdly enough had terrible performance…the same 21:9 1080p video which works fine directly on YouTube using the SFOS browser stutters like crazy in microTube, so it’s clearly not a performance issue.

Now that GPS has been sorted, though, the only remaining major issue is figuring out a decent VPN solution (don’t have a static IP, which complicates matters).

I’m also quite tempted to at some point upgrade to an Xperia 10 III, the performance difference seems to be massive (at least in benchmarks), I wonder if that would resolve my Bluetooth audio desync.

I just installed both on the 10 III (with microG and the correct settings): Uber shows available cars within 10 km of here, Bolt puts me 10 meters east of my location, so pretty good.


@johnflorin you can install OSM Scout server and download your needed maps to the phone and use offline. GPS only without network connection will not work indoor because satellite reception is not possible indoor. The beautiful positioning systems that work ‘everywhere’ use ‘assisted GPS’ and send your data to god knows where.

1 Like

There is native VPN support. OpenVPN works quite well.

1 Like

Thanks for the info, everyone! I managed to get a PPTP VPN going on my Unifi router, via L2TP it simply refused to work on the SFOS side (iOS connected fine) and OpenVPN was not an option on the router.

If anyone else comes across this, I had to put “Authentication via MPPE” as Required for PPTP to work and set up Dynamic DNS via afraid.org, which is still free and is supported for updates directly in the Unifi controller.


For GPS, see what Nekron City / suplpatcher · GitLab can do for you.

1 Like

Thanks, I had come across this, but testing GPS while actually outside yielded good results, I seem to not have the problem mentioned in the big GPS thread, fingers crossed :slight_smile:

1 Like

I also was missing WireGuard support so I gave it a try and wrote a package to integrate it with the system setting UI. I just uploaded it to OpenRepos (WireGuard for Sailfish (Settings UI) | OpenRepos.net — Community Repository System).

Feel free to give it a try. It works fine or my very simple setup (connecting to a single peer that acts as a server) but I expect it to break for more complicated configurations.


This would be awesome! I have several clients connected to my WireGuard VPN, will see if it works when I get back home tonight and whitelist the SFOS client in the WireGuard server.