EU-Soundlimit-disabler no more working - please help!

I’m now testing to modify the file
`/usr/share/lipstick-jolla-home-qt5/volumecontrol/WarningNote.qml .

This script seems to show the ‘accept’ button for the volume control.
I’ll try now to modify it in a way that it immediately does what it does without waiting for the button to be tapped.

That won’t lead you anywhere, I suppose. Can you give this a try? Project: sfos-patch-homescreen-disable-audio-warning

1 Like

Thank you @ichthyosaurus !
But the file opens with Browser on trying to open it in File Browser instead of installing the patch.
How do I have to handle it?

Use Patchmanager Web Catalog to find and install it.

1 Like

Thank you! Now I installed patchmanager from Chum, and menu item appears in Settings, at the end of the first section (Appearance). Patchmanager seems to work.

First I installed on Xperia 10 Dual SIM / SFOS (my experimental phone) and did not look at the patchmanager’s settings, so all items were set to off. I downloaded and installed Disable audio volume warning from web-catalogue

  • it appears in the ‘installed patches’ list.

On checking the ‘enable’ button in the list, an error message occurs: Patch couldn’t be installed.

Then I made the following settings in Patchmanager:
Activate patches on boot - on
allow incompatible patches - off
Convert patches between 32 + 64 bit - on

Tried again to download new from the list, not possible, is indicated as installed, and no possibility to uninstall!

On attempt to re-activate the patch, again the same message: Patch couldn’t be installed.

Next I installed it on SFOS @ Xperia 10 Single SIM. I took care to check the settings before the first download + install try. Installation worked, patch reported as present and activated, but audio warning still present.

Do you want/need additional info for troubleshooting?

You have to long-press an item to open its context menu. There’s an entry “Uninstall”.

I patched the file /usr/share/lipstick-jolla-home-qt5/volumecontrol/VolumeControl.qml from SFOS 3.4. Can you post the contents of the “Patch log” section in Patchmanager? Apply the patch, tap the patch entry, and scroll to the bottom…

1 Like

@ichthyosaurus On the Single SIM phone, AFTER REBOOT! - everything works like a charm!!! Thank you so much!

On the Dual SIM phone still installation possible but activation not possible.
On this phone I hacked a lot inside some files in the last days, trying to find a way to workaround. I think I damaged something, so I will copy this files from the ‘good’ phone to the 'bad? one, reboot and see what happens.

On both phones, I can nowhere find any menu item for patch log!

To restore original files you can

rpm -qf /path/to/edited/file 

That will tell you the package owning it.

cd /tmp
pkcon download /tmp/ packagename
rpm2cpio package-*.rpm | cpio -id

Now the rpm content is extracted in /tmp and you can look at the files and if you want can copy them over the edited ones.

1 Like

On both phones, I can nowhere find any menu item for patch log!

Im patch manager, tap on the patch name in the list after appying failed, you should get a page including the log.

No, only Name, author, version, compatible and description visible. On pulldown, activate patch and deinstall patch. Nothing else.

On the Dual SIM phone I did now replace all files which I’ve earlier editet amateurish. Then it was possible to install the patch without any problems. But did not work.
As on the other phone, reboot was necessary. Now it works fine! Only restarting the Pulseaudio.service is not enough!