EU-Soundlimit-disabler no more working - please help!

The EU soundlimit disabler provided by Penguin in 2014 unfortunately doesn’t work no more since SFOS on Xperia 10.

So may I ask, how does the notification work, and how to permanently remove all scripts, files or whatever related to this functionality, without damaging something other in the system.

Thanks very much in advance !

Untested, but in /usr/share/lipstick-jolla-home-qt5/volumecontrol/VolumeControl.qml

around line 533 I guess you can do something like

533         //onShowAudioWarning: loader.showWarning(initial)
534         onShowAudioWarning: loader.warningActive = false

or just comment out that line. YMMV.

There is also a dconf key /desktop/nemo/audiowarning - which is what the mentioned service/app targets - but that doesn’t seem to be used anywhere.

What that thing also does is:

     chmod -r /etc/pulse/mainvolume-listening-time-notifier.conf

which is the file that configures (or used to?) which audio devices have a warning at all (lineout and headset).

1 Like

No need to edit/alter/hide other files in my limited opinion when you can dconf it!


dconf write /desktop/nemo/audiowarning true

dconf write /desktop/nemo/audiowarning false
1 Like

The line with ‘true’ did nothing,
the line with ‘false’ + reboot had the effect that the headphone no more works. With plugged in headphone, sound of Unplayer comes now out of the speakers.

edit: I did perform the commands as defaultuser in terminal from laptop via ssh.

I tested on my device before posting and it does as expected. I always try to not give bum advice to others. I don’t see why changing that dconf string should affect output methods.

After full reboot of the phone headphone working again, but soundlimit warning unfortunately still present.

edit: my phone is flashed with SFOS, shall I try to change ‘nemo’ to ‘defaultuser’ in the command you gave?

odd, I’m also playing here. It works as expected.

I didn’t give a thought to ‘nemo’ or ‘defaultuser’ as I am using Sony Xperia 10 II which is ‘defaultuser’ by default :slight_smile:

At least you have the sound back as it should be. I’m not sure what to say. There seem to be so many variables per devices here on the forum, the usual ‘it works for most but not for others’; a common theme throughout SFOS history.

Lucky @Edz ! I’ll try with the tips @nephros gave before, that is a little bit more complex, and will report here about the results. :smiley:

I’ve played some more, my results are still the same. I tried a few different approaches.

NO high audio warning when set to true;

[defaultuser@X10II ~]$ dconf read /desktop/nemo/audiowarning


High audio warning shows when set to false;

[defaultuser@X10II ~]$ dconf read /desktop/nemo/audiowarning


Restart pulseaudio.service (systemctl --user restart pulseaudio.service) after each DCONF write

Close music player if open.

Unplug and plug back in headphones.

Open music player, the audio warning should now be working or not depending on true or false of course.

Edit: hang on, when set to false it shows warning and when set to true warning does not show??, that can’t be right??, surely that should be the other way around <------muttering to myself!!

Yes @Edz , this works now.
Thank you so much!! :smiley:

1 Like

Replying to myself to highlight an apparent problem;

Despite my notes above, there is no need for restarting pulseaudio, unplugging/replugging headphones or closing/reopening media player.

I am able to set the warning on or off on the fly with music playing.

The problem I see, is already mentioned;
setting to FALSE allows the warning to SHOW, but setting to TRUE prevents the warning from SHOWING.

It’s possible the meaning of the key is “did we show a warning yet?”, hence setting it to true will disable it.

In my case it did not work before restarting pulseaudio.service, but after it did ! Music player was closed anyway. Unplug/plug the headphone was a voluntary extra task… On new opening the music player, the annoying message was gone and it still is!

edit: to summarize it, enter in terminal:

dconf write /desktop/nemo/audiowarning true [Enter]
systemctl --user restart pulseaudio.service [Enter]

…works, soundlimit warning is gone.

edit: it didn’t help very long, warning came back after one day - edit: and a reboot

@nephros around the line 533 i couldn’t find anything related to the audiowarning issue. But beginning with line 398 there is a function ‘Loader’, where in line 404 is:
warningActive = true

I changed this now into
warningActive = false

and am curious what will happen in the next days.

Problem was, that the solution @Edz provided, only worked for a day on one of my two phones. Then the warning came back.

Yes, I was looking in the version for 4.2, apparently something changed.

Anyway, the loader is there for the warning popup itself; but there must be a call to that loader component somewhere, maybe not exactly on line 533 but somewhere.

1 Like

Yes, beginning with line 459 there is a function ‘connections {
target: volumeControl …’.
Looks to me like this is for the volume control and handling the input from the vol up and vol down buttons.
In line 525 is: onShowAudioWarning: loader.showWarning(initial)

Is it senseful to comment out this line?

Well if you do the popup loader should never get called - so yea.

@nephros I will wait with commenting out line 525, have now another problem to solve before:

After changing line 404 from true to false and rebooting the phone, the vol up bar sticks now at the limit but no accept field appears .

edit: so I brought everything back in the original state.

it seems any and all is possible with this one, I agree, but at the very least, it is somewhat ambiguous.

1 Like

I found now in line 35 a comment:

  // The maximum continuous volume that should be allowed. Plus one so that the warning is triggered.

and in line 36 a complex formula that contains something with restrictedVolume. So I ask myself, where is this restricted volume level defined? and can I set it simply to a higher level, so that the warning is never triggered without any other changes?

edit: The formula in line 36 + 37 is:
var max = (controllingMedia && volumeControl.restrictedVolume !== volumeControl.maximumVolume)
? (volumeControl.restrictedVolume+1) : maximumVolume

is it possible to replace ‘volumeControl.restrictedVolume’ with a number, so that the real volume never triggers the warning? Where is this variable defined? Can I change some config file to set ‘volumeControl.restrictedVolume’ to a higher value?
In what range is this value? Beginning from zero, I have to short push the vol up button 11 times until warning pops up. Can I simply replace ‘volumeControl.restrictedVolume’ with a number, e.g. 16 ?