Email: copy-pasted numbers are always phone numbers?

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48 (Koli)
HARDWARE (XA2, Xperia 10…): XA2 Ultra
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): No

DESCRIPTION:

When you want to copy-paste a number (however long) from your email, it is always interpreted as a phone number, and gets preceded by “tel:” in the paste buffer.

PRECONDITIONS:

Working email client.

STEPS TO REPRODUCE:

  1. Start email client
  2. Open an email with a number in it, it gets underlined as a hint it is selectable
  3. Press and hold the number
  4. You get a menu with Call / Share / Copy to clipboard, select the last one
  5. Paste the “number” somewhere, and find that it has had “tel:” tacked in front

EXPECTED RESULT:

When one does “copy to clipboard” you expect the number to be copied as it is, because this is the whole point of copy-paste.

ACTUAL RESULT:

What’s in the clipboard is “tel:” and the number from your email.

ADDITIONAL INFORMATION:

This “feature” is very inconvenient, as it makes using “virtuaaliviivakoodi” (54 digits long) in emailed bills very difficult if not nearly impossible to use with mobile banking software. For example, the Danske Bank mobile bank will only accept 54 characters from the paste buffer and truncate the rest, making what you just copied an invalid “virtuaaliviivakoodi”. It might be possible to copy-paste just the digits using the selector tools but it is a very tricky operation compared with the “copy to clipboard” option.

2 Likes

Is your email client an Android app?

Namely, when extracting a number from Sailfish Email app, no popup menu appears. Instead, the notification “Copied to paste buffer”.

If you then paste the number to Sailfish Notes or to Android Whatsapp, this number is pasted as is, i.e. there is no prefix.

1 Like

I’m also using the Sailfish email application. The difference seems to be that the email message I am attempting to copy the text from is plain text (like the majority of my emails), it seems this does not happen with html formatted emails where you get the normal text selector tool which doesn’t mess the clipboard content?

The same thing happens in plain text messages to text strings which look like email addresses, they get mailto: tacked on in front when you copy-paste them.

I do confirm that behaviour.

@jovirkku it seems you are also used to copy text only after answering/forwarding? Then it works as expected.
But when you select directly from the opened mail (in read mode) then this behaviour of prepending tel:/mailto: shows up.

1 Like

After some nice discussion in the community meeting, it looks like the “Tel:” prefix is being injected so that the numbers can be shown as a link by the browser renderer. This gets put directly into the clipboard when the “url” is pasted. Here’s the place it seems to happen, and I think it’d be an easy fix, in case anyone fancies proposing a PR to do so: https://github.com/sailfishos/sailfish-components-webview/blob/master/import/popups/ContextMenu.qml#L164

It’d probably be worth fixing for mailtos at the same time. The type of link has already been identified by the code, as can be seen here: https://github.com/sailfishos/sailfish-components-webview/blob/master/import/popups/ContextMenu.qml#L109

3 Likes