Editor App not working properly

with on an XA2 Ultra

when i open Editor from the desktop icon and try to Open i get a very restricted list of directory in /home/nemo
particularly none of the ones i created previously appear
if i launch harbour-editor from the terminal i can see the whole content of /home/nemo

I have the same issue. Don’t know for sure, but app seem to be abandoned by dev.
Any way, as a workaround I use qCommand to open Editor from cli and to create a launcher in drawer.
If you need Editor to have root access you can create another launcher in qCommand like below.

devel-su env XDG_RUNTIME_DIR=/run/user/100000 WAYLAND_DISPLAY=../../display/wayland-0 harbour-editor

Another ‘workaround’ is to use the excellent tIDE instead.

1 Like

Please read up on SailJail.
It is possible to turn off per app if you really want.

1 Like

Yes I remembered later. I’m just stuck on my own old behaviour.

could you be a little more specific
i am not a developer
what to do ?

Do you mean this editor: Editor. | OpenRepos.net — Community Repository System ?

Not dev either unfortunately but hope this helps.
Not that if you make a mistake (or if I do :–) ), this could compromise the good working of your device.
SailJail encloses the apps to allow them accessing only specific things.
But you can disable this. Because you are on SFOS. Because you can access lots of things in SFOS :heart: !

-Go to Settings > Developer tools and enable dev mode, set a password
-Open a terminal from the new icon that appeared in appgrid


then input the pw you sat. (to become root and be able to edit system files)

-Make a copy of the file you will edit. In case of user defaultuser:

cp -a /usr/share/applications/harbour-editor.desktop /home/defaultuser/Documents/

Now, add some text to the end of the file to disable SailJail:

echo “[X-Sailjail]” >> /usr/share/applications/harbour-editor.desktop


echo “[X-Sailjail]” >> /usr/share/applications/harbour-editor.desktop

You can now exit from terminal with the key combination (twice):


And disable Dev mode.
You should now be able to poke around all your files with Editor.