E-Mail: Select and copy text to the clipboard

I just got an e-mail that a training today is canceled. Now I want to send this information to people of whom I only have SMS- or Signal-contacts … I had to write it again.

Goal:
A long tap on a text in “E-mail” should enable to choose start- and end-point of a marked text, which is copied to the clipboard. Opening other apps (SMS, Signal, …) it should be possible to paste the copied text. Would be helpful.

1 Like

The only way I’ve found to do this is to use the forward email option (without actually forwarding the email to anyone). Once the forwarded email is on the screen you can then select and copy the text.

The disadvantage is that when you paste it you then have to edit out all of the ‘>’ characters at the start of each line. Its a pain in the rear, but better than retyping.

1 Like

I just tried it: Forwarding doesn’t help, because the text is appended only. But if I use “reply” your way works, thank you.

Yes, on reflection I think I got that bit wrong, and you are right it is ‘reply’ - otherwise you wouldn’t get the ‘>’ characters.

You can copy text from emails, you just have to tap a word for a loooong time, then the word gets selected and the selection markers appear. By lo g i mean a few seconds.

2 Likes

Honestly, it doesn’t work. You can hold your finger on a word in an email for 60 seconds or more and it won’t bring up the text selector.

Hi Miau, you are right! It takes two seconds and the word is marked, I also can choose to mark all, nice.
I agree, “one second” would be long enough for me.

(Edit: There is no option “solution”, but this question is solved!)

1 Like

Hmmm… So how come this won’t work for me? I’m on 4.4.0.64 on Xperia 10 III. Would it make any difference if the email received was in plain text rather than HTML I wonder?

Ok, this is interesting. If the email just contains text, then you are both right - it does work. But if there is any image in the email then it doesn’t work - or at least I can’t get it to work. Can anyone else confirm this behaviour?

1 Like

Works for me for text-only and HTML (images) emails. On XA2.

It might just be that it works where the markup/styles as interpreted by the browser would allow selection.
I sometimes find sites where I cant long click to copy, so emails would be a similar subset.

I can confirm this. 3s.

But reply/forward is also an easy enough option IMO.

@Steve_Everett - have you checked if maybe the email is at fault, and not SFOS? In other words, test it on a different device, test with different emails.
I receive mostly text emails, but they can be actual full web pages, with all the dis/advantages that brings.